Stalling at idle, possible fuel pump? - Page 2 - GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat

2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Stalling at idle, possible fuel pump?

Reply

 
 
 
Old 05-04-2009, 11:07 PM
  #11  
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

Where about on the UIM is the hissing coming from? With the animal issue and the noise, you might have a vacuum leak. Get some carb cleaner and spray it by vacuum lines while the car is running, if the engine rev'*, then you've found the are where the leak is.
Purplehazeir is offline  
Reply With Quote
Old 05-05-2009, 08:54 AM
  #12  
Senior Member
Posts like a Turbo
 
lordvader's Avatar
 
Join Date: Sep 2008
Location: Philadelphia, PA
Posts: 332
Thanks: 0
Thanked 0 Times in 0 Posts
lordvader is on a distinguished road
Default

i had the same problem thought it was a fuel pump so i put a new one in all that fixed was the gas gauge. it turned out to be a mass air flow sensor so i would have that checked first before you start spending money oh by the way the oil pressure switch on your car needs to be replaced to fix the gauge problem its really cheap to do.
lordvader is offline  
Reply With Quote
Old 05-05-2009, 03:15 PM
  #13  
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 20 Times in 16 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I think we handled the MAF already, if not you only need to unplug it and see if the car runs better.
Danthurs is offline  
Reply With Quote
Old 05-05-2009, 04:50 PM
  #14  
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Dec 2005
Location: Ann Arbor, MI
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Vert032 is on a distinguished road
Default

Well, I replaced the fuel pump today and that didn't make a difference, but as soon as I saw that about the MAF I disconnected it and it'* running 'fine'. Not perfectly crisp, but it'* steady and not stalling / sputtering.

That seems to be the problem, I'm going to pull and clean it and if that doesn't work I'll replace it.

Thanks everyone for all of your help!
Vert032 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kamikaze78
Chevrolet
5
10-14-2014 07:12 AM
skips45acp
Oldsmobile
1
08-16-2013 09:46 AM
lesbray
1992-1999
1
08-23-2009 08:40 PM


Thread Tools
Search this Thread
Quick Reply: Stalling at idle, possible fuel pump?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.