P1404, replaced egr twice, that else causes 1404? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-11-2009, 04:38 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2006
Location: yanceyville, nc
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
68widetrack is on a distinguished road
Default P1404, replaced egr twice, that else causes 1404?

2001 SLE 108K, 120 mile commute everyday. Had P1404 code last August, replaced EGR valve (Advance). Last week it is setting P1404 again. Inspected old EGR elec. connection, gasket looked fine, replaced EGR (1yr warranty). Drove only a few miles this morning and it came back on. Any suggestions?
I think this is separate issue but I had the oil pressure gauge pegging, so as per forum advice I replaced the oil pressure sending unit. Although it had only been 700 miles since oil change I thought I might have a bad filter so I changed oil again. Now the oil pressure gauge bounces around. Can the oil pressure variation cause the SES for P1404? I'd rather be working on and spending money on my '68 Bonn. Conv. than the SLE, help me out guy'*, Thanks
68widetrack is offline   Reply With Quote
Old 01-11-2009, 04:53 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Check for vac leaks. Sometimes you can get odd errors with a vac leak.
Danthurs is offline   Reply With Quote
Old 01-31-2009, 08:27 PM   #3
Member
Posts like a V-Tak
 
Join Date: Nov 2008
Location: rice lake
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
bonneville dan-o is on a distinguished road
Default

unplug the egr valve. turn the key on and clear the code. then plug it back in. give that a try sometimes it work
bonneville dan-o is offline   Reply With Quote
Old 02-01-2009, 11:25 AM   #4
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Googling, searching here .. I'm off to do this. I since no one is listing what the name of this code is..it'* tough to guess. =0)

I'm back:
P1404 Exhaust Gas Recirculation Closed Position Performance.
Got some good info, then consulted my 98 fsm'* as they are all the same for EGR type stuff. The info looks like it suggests checking the connections at the pcm and egr, ensuring looking at the pins to make sure they aren't backed out. Pulling the valve and manually operating it to ensure there is no sticking.

Says that the pcm learns the closed position when the ignition is turned on. It later compares that to where the valve is when commanded closed.

Last edited by BillBoost37; 02-01-2009 at 11:32 AM.
BillBoost37 is offline   Reply With Quote
Old 02-01-2009, 01:55 PM   #5
Senior Member
Posts like a 4 Banger
 
gtpsuprchrgd03's Avatar
 
Join Date: Sep 2008
Location: Montgomery County MD
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
gtpsuprchrgd03 is on a distinguished road
Default

Damnn.. I just got the same exact code on my 01 SSEi. I ma look into it tomorrow at work!!
gtpsuprchrgd03 is offline   Reply With Quote
Old 06-03-2009, 05:36 PM   #6
Junior Member
 
Join Date: Jun 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Shannow is on a distinguished road
Default

I hate to bump an old post. But I am getting the same error. The valve has been replaced new. But still the same thing. I went in and reset the SES light with a reader, but after a while, it came back one.

Also, unrelated, I am getting the anti lock, brake, and airbag lights on my dash (these have been coming up for a long while though, even after replacing pad/rotors,etc). A friend said I may just need a new ECM, or to have my current one updated. I am pretty novice at this, but might that be the cause for both the SES and other lgihts?
Shannow is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
99 SSEI EGR EVAP P1404 Problems 99BlackSSEI 1992-1999 5 12-31-2012 11:10 AM
00 bonneville SE ig. moduel replaced twice+ sps62487 2000-2005 5 06-28-2007 10:24 AM
P1404 and P0336 even with known good EGR valve Hans 2000-2005 9 01-29-2007 12:40 PM
EGR low flow. Replaced EGR, still getting code 1997_LeSabre 1992-1999 8 04-20-2005 10:06 AM
Code 1404 EGR Help please....? Black bonneville 2000-2005 1 05-24-2004 03:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:41 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.