DIC indicates low brake fluid - how to reset - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-26-2009, 12:10 AM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
searay268 is on a distinguished road
Angry DIC indicates low brake fluid - how to reset

I was coming down a hill the other day and had to hit the brakes hard to come to a stop. When I did this the "Low brake fluid" light came on the DIC and the brake light came on as well. When I got home, I put the car in the garage on level ground and the level was above the minimum line. I went ahead and topped it off anyway (did not think about level going down because of brake wear). I really don't think it is leaking, I think it was a combination of brake wear lowering the level and then stopping hard downhill allowing the fluid to slosh away from the sensor or whatever is in the master cylinder.

Anyway, I cannot find a way to reset the warning. I have tried holding down the reset button and I tapped on the master cylinder in case there is a float gauge in it that may be stuck. Nothing has helped. The local dealer says come on over, give them $65.00 and they can reset the code. Is there anything I can do to reset this?

Thanks
searay268 is offline   Reply With Quote
Old 06-26-2009, 12:46 AM   #2
Senior Member
Posts like a Turbo
 
PaulPool's Avatar
 
Join Date: May 2009
Location: NJ
Posts: 257
Thanks: 0
Thanked 0 Times in 0 Posts
PaulPool is on a distinguished road
Default

Well I can't help you with a permanent fix, but if you need to pass inspection soon I have two words for you: Black Tape. It'* worked before, hah hah.
PaulPool is offline   Reply With Quote
Old 06-26-2009, 01:46 AM   #3
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

Quote:
Originally Posted by searay268 View Post
Is there anything I can do to reset this?
Disconnect the negative battery cable, wait a minute, reconnect and see. Or drive to Autozone, ask them to scan and clear the code.
Purplehazeir is offline   Reply With Quote
Old 06-26-2009, 11:13 AM   #4
Senior Member
Posts like a Supercharger
 
Join Date: Feb 2009
Location: Chicago, IL
Posts: 188
Thanks: 0
Thanked 0 Times in 0 Posts
obnoxus is on a distinguished road
Default

when the display shows the fault,,,,, press reset on the dash
obnoxus is offline   Reply With Quote
Old 06-26-2009, 02:38 PM   #5
Junior Member
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
searay268 is on a distinguished road
Default

I have tried the reset button numerous times.

I'll try disconnecting the battery.

Thanks
searay268 is offline   Reply With Quote
Old 06-27-2009, 10:42 AM   #6
Junior Member
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
searay268 is on a distinguished road
Default

No joy. Disconnecting the battery did not help either.
searay268 is offline   Reply With Quote
Old 06-27-2009, 11:03 AM   #7
Senior Member
Posts like a Supercharger
 
Join Date: Feb 2009
Location: Chicago, IL
Posts: 188
Thanks: 0
Thanked 0 Times in 0 Posts
obnoxus is on a distinguished road
Default

gotta be a bed sensor then.
obnoxus is offline   Reply With Quote
Old 06-27-2009, 12:14 PM   #8
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

Quote:
Originally Posted by searay268 View Post
No joy. Disconnecting the battery did not help either.
Try Autozone for a scan and have them clear any codes.
Purplehazeir is offline   Reply With Quote
Old 08-21-2009, 01:56 PM   #9
Junior Member
 
Join Date: Aug 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
vandedm is on a distinguished road
Default

I am having the same problem. It was a bit low so I added fluid; light still on.

Unplugging the sensor makes the light go off so I replaced the sensor...still says brake fluid low.

Of course, tried holding in the reset button on the DIC. I am beginning to suspect something in the white plastic reservoir is not quite right.

No check engine light is on, only the red brake (warning light) and the "Brake Fluid Low" message in the DIC.

Last edited by vandedm; 08-21-2009 at 02:00 PM.
vandedm is offline   Reply With Quote
Old 08-21-2009, 02:53 PM   #10
Junior Member
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
searay268 is on a distinguished road
Default

Yeah, we had to have the brake reservoir replaced. That fixed it.
searay268 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'03 Lesabre low tire pressure light reset Mike from Cle Buick 7 08-24-2014 11:43 AM
brake fluid low nino515 2000-2005 1 10-26-2006 07:36 PM
Low coolant loght on @ DIC SSEBONNE4EVA 1987-1991 6 03-28-2005 11:56 AM
Cannot Reset DIC Trip AVG MPG Display 95SLE 2000-2005 4 06-18-2004 09:09 AM
DIC Reports "Low Coolant" Merlin 91/97 1987-1991 12 06-25-2003 04:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:53 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.