2003 SSEI HUD is not working - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-13-2009, 09:25 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
jaymarhonda is on a distinguished road
Question 2003 SSEI HUD is not working

Is this a fuse issue? I purchased this vehicle last week and everything but the HUD is in great condition. Should I leave this to a dealer to handle? I thought the HUD is not that important at first but I changed my mind and would like to have that fixed.
jaymarhonda is offline   Reply With Quote
Old 07-13-2009, 09:38 AM   #2
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

have you adjusted it all the way up and all the way down To see if you can see the image. After you have done this test. When its dark out, have some one do the same thing, and have a look through the windshield into the HUD unit to see if the VF display is on/working
1993 SLE is offline   Reply With Quote
Old 07-13-2009, 09:56 AM   #3
Junior Member
Thread Starter
 
Join Date: Jul 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
jaymarhonda is on a distinguished road
Default

Yes. I tried that both during the day and night. The HUD is dark and unresponsive. Is there a fuse for this?
jaymarhonda is offline   Reply With Quote
Old 07-13-2009, 10:21 AM   #4
Senior Member
Posts like a Northstar
 
Nobotada84's Avatar
 
Join Date: Apr 2009
Location: Indianapolis, Indiana
Posts: 699
Thanks: 0
Thanked 0 Times in 0 Posts
Nobotada84 is on a distinguished road
Default

Rear fuse block

Labeled: IP
fuse #30
10 amp
Nobotada84 is offline   Reply With Quote
Old 07-13-2009, 12:05 PM   #5
Junior Member
Thread Starter
 
Join Date: Jul 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
jaymarhonda is on a distinguished road
Default

Looked at this and fuse seemed to be fine. replaced it anyway. no luck.
jaymarhonda is offline   Reply With Quote
Old 07-14-2009, 04:09 AM   #6
Member
Posts like a V-Tak
 
Black01SSEi's Avatar
 
Join Date: Jun 2009
Location: Georgia
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Black01SSEi is on a distinguished road
Default

Looks like the dealer needs to check the problem with your HUD. You will like it once you get it back running again.

You can sometimes find them on ebay used for a much better price then buying a new unit at the dealer. check ebay and see if they show one if that is what you need.

Good Luck with your new Bonneville
Black01SSEi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Speedometer and HUD not working ynos069 Bonneville GXP/ Northstar Powered Cars 0 03-26-2010 02:54 PM
1995 SSE HUD not working SSP_SSE Everything Electrical & Electronic 6 08-14-2008 11:31 PM
Twilight Sentinel working then not working on '95 SSEi mrstangblb 1992-1999 1 12-03-2004 09:30 PM
Common things to check when HUD not working? Foghorn Everything Electrical & Electronic 10 03-16-2004 10:33 PM
HUD not working Austin 1992-1999 5 03-26-2003 11:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:53 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.