Common things to check when HUD not working? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-30-2004, 01:01 PM   #1
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jan 2004
Location: Montréal, QC
Posts: 1,374
Thanks: 0
Thanked 0 Times in 0 Posts
Foghorn is on a distinguished road
Default Common things to check when HUD not working?

I've done a search on this topic and haven't found much info, it'* probably here somewhere but I just haven't found it.

I've been looking to acquire an SSEi recently and have just purchased a 40th Anniversary SSEi that I pick up tomorrow. Funny thing is that on three 1997 to 1998s that I saw, none of the HUDs worked!

Is there something common that fails on these cars? It'* quite a coincedance none of them worked...just a fuse or likely something else?

Any tips would be much appreciated.

Cheers,
Foghorn is offline   Reply With Quote
Old 01-30-2004, 02:48 PM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

I have not heard of any common problems with those. I would start with the fuses. One guy had a problem with one of the components on the circuit board burning up.

http://www.bonnevilleclub.com/forum/...pic.php?t=8789
fuddyduddy121 is offline   Reply With Quote
Old 01-30-2004, 03:22 PM   #3
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

I'll have to agree. The link Fuddy posted is the first HUD failure I've heard of.
willwren is offline   Reply With Quote
Old 01-30-2004, 04:10 PM   #4
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jan 2004
Location: Montréal, QC
Posts: 1,374
Thanks: 0
Thanked 0 Times in 0 Posts
Foghorn is on a distinguished road
Default

Thanks guys...looks like the fuse is obviously the first place to check (where ever that'* located LOL)

Cheers,
Foghorn is offline   Reply With Quote
Old 01-30-2004, 05:37 PM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

I might be mistaken, but I believe it'* above the passenger footwell hushpanel.
willwren is offline   Reply With Quote
Old 02-06-2004, 02:45 PM   #6
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default Re: Common things to check when HUD not working?

Quote:
Originally Posted by Foghorn
Funny thing is that on three 1997 to 1998s that I saw, none of the HUDs worked!
Pardon a dumb question, but are you sure? I know on mine, if you don't have the angle dialed in right, you won't see anything at all. Similarly, the "dimmer" slide will switch it completely off when it'* slid all the way to the bottom.

So if you've got the dimmer all the way up, and looked right down at them through the windshield, and they're dead, then I think I'd start with the cluster connections and see if they're loose or broken, especially if there are other dash gauge weirdnesses to see as well.
acg_ssei is offline   Reply With Quote
Old 02-06-2004, 05:53 PM   #7
Senior Member
True Car Nut
 
Join Date: Dec 2003
Location: Corn Fields, IN
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
John Deere Boy is on a distinguished road
Default

The HUD dimmer or rheostat on my car has gotten kinda screwey and sometimes the HUD will cut out and you need to bump the dimmer and it will come back on. My dash lights are the same way, but it seems to be a common problem with those.
John Deere Boy is offline   Reply With Quote
Old 02-06-2004, 06:14 PM   #8
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jan 2004
Location: Montréal, QC
Posts: 1,374
Thanks: 0
Thanked 0 Times in 0 Posts
Foghorn is on a distinguished road
Default Re: Common things to check when HUD not working?

Quote:
Originally Posted by acg_ssei
Pardon a dumb question, but are you sure?
Yep, I'm sure. I've had HUDs before and so I checked them out thoroughly thinking what a drag such a neat toy doesn't work. I played with height and dimmer adjustments, no help. Since they were used cars...think somebody might have pulled the dash thinking they could change the digital odometer readings?

Cheers,
Foghorn is offline   Reply With Quote
Old 02-08-2004, 11:09 AM   #9
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default Re: Common things to check when HUD not working?

Quote:
I played with height and dimmer adjustments, no help.
I'd check to see whether the rheostat has any power coming in. The most likely problems in the dash seem to be either oxidized pin connections, which can be cleared up just by taking them apart and putting them back together again, or toasted rheostats in the headlight switch or the HUD dimmer as you describe.

Quote:
Since they were used cars...think somebody might have pulled the dash thinking they could change the digital odometer readings?
Well, I dunno about the later years, but the '93 HUD doesn't show odometer readings anyway. The only way to change the odometer on the electronic DIC display would be to find and replace whichever module holds that memory. I'm sure it'* in the manual but I never to looked to find out which it was.

I'd say it'* more likely you just have some bad pin connections somewhere. Maybe somebody did go in to try and swap out the odometer somehow, then messed up the HUD connections when trying to put it all back together. (If that'* the _only_ thing they messed up, I'd be surprised... )
acg_ssei is offline   Reply With Quote
Old 02-08-2004, 06:40 PM   #10
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jan 2004
Location: Montréal, QC
Posts: 1,374
Thanks: 0
Thanked 0 Times in 0 Posts
Foghorn is on a distinguished road
Default

Thanks for the feedback guys. I had the car in a garage over the weekend to give it a good going over and a thorough cleaning.

I checked the fuses and relays, took each one out to inspect and clean it then put it back in. The HUD is now working, though it was adjusted to it lowest possible position. I'm wondering what it was, but it seems all is working...nice to have a HUD again!!

Cheers,
Foghorn is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
common issues, common fixes enslow Forum updates and suggestions 1 01-09-2010 03:02 PM
2003 SSEI HUD is not working jaymarhonda 2000-2005 5 07-14-2009 04:09 AM
1995 SSE HUD not working SSP_SSE Everything Electrical & Electronic 6 08-14-2008 11:31 PM
HUD not working Austin 1992-1999 5 03-26-2003 11:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:34 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.