Water in UIM ??? - Page 5 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-24-2006, 06:25 PM   #41
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2006
Location: Canada
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
mysterio is on a distinguished road
Default

I replaced the coil in question and the car is much better. So it was the coil. Car still running sluggish and posted another issue with the gas filter replacement issue.

Thanks...
mysterio is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Water, Water. Water !!!! da_grey_goose_95 Detailing & Appearance 6 02-19-2010 12:36 PM
Help - did my UIM/LIM - engine suckingn water? chantspel Pontiac 6 10-12-2009 06:30 PM
UIM and LIM replaced now leaking coolant out of UIM gasket Paul1981 2000-2005 10 12-21-2007 11:05 PM
Water Leak around the water pump! BigAl 1992-1999 20 01-28-2003 01:38 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.