Is there something wrong with my cooling system? - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-09-2005, 04:06 PM   #11
Senior Member
True Car Nut
Thread Starter
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

My mechanic wants the car on Friday. He thinks the thermostat is sticking, and since we have never replaced or flushed he wants to do that. After seeing some of the other posts, this probably won't fix the "problem" as it might just be the way it is. I'll be putting a 195 back in. We'll see Friday night if anything changes.
sonoma_zr2 is offline   Reply With Quote
Old 03-11-2005, 05:08 PM   #12
Senior Member
True Car Nut
Thread Starter
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

Well, the priliminary results are good. I have yet to drive it home, but what little I did drive this noon looks promising. The "base line" sits a little below 200 (or a little left of straight up), and swings a little above 200. Will know more tonite after the drive home.
sonoma_zr2 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
cooling fans, CTS, and temp gauge ain't doing there jobs skregal 1992-1999 10 06-04-2007 07:13 PM
Wrong place at the wrong time.. UPDATE bonnie94ssei Forced Induction 19 09-17-2006 06:39 PM
There's something wrong with the world today Maymybonnieliveforevr Lounge 4 05-16-2006 10:05 PM
Wrong Just Wrong BLACK94SSEi Lounge 24 03-30-2006 11:44 PM
I think there was something wrong with my O2 sensor J Wikoff 1992-1999 16 12-28-2005 12:32 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.