I think there was something wrong with my O2 sensor - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-27-2005, 06:44 PM   #1
Senior Member
Certified Car Nut
Thread Starter
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default I think there was something wrong with my O2 sensor

What do you think? It'* not quite right...





J Wikoff is offline   Reply With Quote
Old 12-27-2005, 07:03 PM   #2
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

OMG...please tell me that you did the AFTER you took it out
1993 SLE is offline   Reply With Quote
Old 12-27-2005, 07:05 PM   #3
Senior Member
Certified Car Nut
Thread Starter
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

Nope, it was that way when I took it out. I can't imagine anything hit it, she'* running good, so my plugs and valves are intact. I'm thinking it got really hot.
J Wikoff is offline   Reply With Quote
Old 12-27-2005, 07:13 PM   #4
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Twin Falls, Idaho
Posts: 7,545
Thanks: 0
Thanked 1 Time in 1 Post
Hans is on a distinguished road
Default




so uh thats why the gas miliage sucks
Hans is offline   Reply With Quote
Old 12-27-2005, 07:15 PM   #5
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

yes a O2 that looks like that is indication of a Lean Condition and really HOT exhaust gas
1993 SLE is offline   Reply With Quote
Old 12-27-2005, 07:18 PM   #6
Senior Member
Certified Car Nut
Thread Starter
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

Quote:
Originally Posted by 1993 SLE
yes a O2 that looks like that is indication of a Lean Condition and really HOT exhaust gas
Yep, the A/F gauge has been showing rich for about a month. The sensor failed toward the rich side and the ECM thought it should lean it out. The new one finally arrived from GMPD.
J Wikoff is offline   Reply With Quote
Old 12-27-2005, 07:24 PM   #7
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

I have never seen an O2 fried like that.... WOW

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 12-27-2005, 08:12 PM   #8
Senior Member
True Car Nut
 
Jack's Avatar
 
Join Date: Sep 2005
Posts: 3,105
Thanks: 0
Thanked 0 Times in 0 Posts
Jack is on a distinguished road
Default

Holy CRAP, what have you been adding to your fuel?
Jack is offline   Reply With Quote
Old 12-27-2005, 08:13 PM   #9
Senior Member
Certified Car Nut
Thread Starter
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

Nothing but 93 octane, sometimes 91 when it'* really cold outside.
J Wikoff is offline   Reply With Quote
Old 12-27-2005, 08:37 PM   #10
Senior Member
True Car Nut
 
Jack's Avatar
 
Join Date: Sep 2005
Posts: 3,105
Thanks: 0
Thanked 0 Times in 0 Posts
Jack is on a distinguished road
Default

Quote:
Originally Posted by J Wikoff
Nothing but 93 octane, sometimes 91 when it'* really cold outside.
Huh, I've seen them get messed up from mixing in Nitrous-methane but never that bad.
Jack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
A Bad TPS sensor or something else (Throttle position sensor) DeathDealer General GM Chat 17 03-27-2017 10:30 PM
Wrong place at the wrong time.. UPDATE bonnie94ssei Forced Induction 19 09-17-2006 06:39 PM
There's something wrong with the world today Maymybonnieliveforevr Lounge 4 05-16-2006 10:05 PM
Wrong Just Wrong BLACK94SSEi Lounge 24 03-30-2006 11:44 PM
Is there something wrong with my cooling system? sonoma_zr2 1992-1999 11 03-11-2005 05:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.