car wont start after new fuel pump install - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-11-2005, 02:59 AM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2005
Location: dallas, tx.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
guzzz is on a distinguished road
Default car wont start after new fuel pump install

whats up guys, well i have this problem trying to get my car to start. it all began when a loud annoying humming noise was coming from inside the fuel tank. im pretty sure it was a failing fuel pump.( the car would also stall sometimes while driving) service engine light would stay on. well, i replaced the fuel pump with a new one and after installing everything back together with 5 gallons of gas my car would crank but not start. i depressed the fuel pressure valve and no gasoline would come out. i thought it could have been that the new pump was bad. So, i exchanged it for another one and installed it and the same thing happened, the car would not start. I switched the ign to on and the pump sounded like it was working. New fuel pump and strainer used.
p.*. i found a small very tiny rubber ball on the ground when i was removing the pump from the sending unit. Im not sure if it fell of the unit or if it has been there for a while. im thinking maybe this ball has something to do with it, maybe not. Please help.
guzzz is offline   Reply With Quote
Old 03-11-2005, 03:08 AM   #2
Senior Member
Posts like a Northstar
 
Join Date: Apr 2004
Location: Minneapolis, MN
Posts: 566
Thanks: 0
Thanked 0 Times in 0 Posts
CSFiend is on a distinguished road
Default

I haven't done a pump in an H-Body in a long time, but isn't that part of the check valve?
CSFiend is offline   Reply With Quote
Old 03-11-2005, 01:13 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2005
Location: dallas, tx.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
guzzz is on a distinguished road
Default

im not sure what a check valve is.
guzzz is offline   Reply With Quote
Old 03-11-2005, 03:10 PM   #4
Senior Member
Posts like a Northstar
 
Join Date: Apr 2004
Location: Minneapolis, MN
Posts: 566
Thanks: 0
Thanked 0 Times in 0 Posts
CSFiend is on a distinguished road
Default

A check valve prevents gas from leaking back into the tank. If it leaks back, you'll have a no-start condition until the pressure builds back up.
CSFiend is offline   Reply With Quote
Old 03-11-2005, 05:59 PM   #5
Junior Member
Thread Starter
 
Join Date: Mar 2005
Location: dallas, tx.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
guzzz is on a distinguished road
Default

thanks CSFiend for the quick response. After 3 days of trying to start the car and changing the fuel pump twice it finally started working. Just out of couriosity i went to jiggle the fuses and relays under the dash on the pass side and then decided to give the key one last turn and "presto" darn car turned on out of no where. Maybe the relay had something to do with it or maybe the poor bonnie just wanted to rest for a few days.
guzzz is offline   Reply With Quote
Old 03-11-2005, 06:03 PM   #6
Junior Member
Thread Starter
 
Join Date: Mar 2005
Location: dallas, tx.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
guzzz is on a distinguished road
Default

thanks CSFiend for the quick response. After 3 days of trying to start the car and changing the fuel pump twice it finally started working. Just out of couriosity i went to jiggle the fuses and relays under the dash on the pass side and then decided to give the key one last turn and "presto" darn car turned on out of no where. Maybe the relay had something to do with it or maybe the poor bonnie just wanted to rest for a few days.
guzzz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
fuel pressure / leak after new fuel pump static1701 2000-2005 10 12-30-2014 10:10 PM
2008 Suzuki XL7 wont start after fuel fill tst2620 Lounge 7 06-06-2014 09:15 PM
Fuel Pump wont pump skips45acp Oldsmobile 1 08-16-2013 10:46 AM
Cranks for 10+ seconds before firing after a new fuel pump install t1475dt 2000-2005 11 01-20-2010 08:33 PM
96 LSS wont start, fuel pump relay clicking rapidly james5275 1992-1999 2 02-06-2008 12:51 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:33 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.