oil pump (sensor?) problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-14-2006, 01:12 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jun 2005
Location: Mcallen TX
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Paco.McGraw is on a distinguished road
Default oil pump (sensor?) problem

Hey yall. Thanks again for your help with the problem I had with the evap unit.

Im havin a problem with my oil gauge. When I turn on the car, it pops up past the 120 line and stays there till the car gets up to temp (bout 200 or a little less). After the car is up to temp, the needle goes down to just above the red line when idle and pops back up to 120 when I give some gas. When the needle hits the bottom, I get the SES light but when I give it some gas and the needle pops back up the SES light goes away. This has been goin on for quite some time though. It started in mid September of 2004 and I wrecked the car October 31 of 04. Since then Ive been doin the body work and minor mechanical work.This past weekend I finally got the car to the point of being drivable and safe with the exception of the oil problem Im havin. I changed the oil on Sunday and the old oil was a bit dark (as old oil is) but otherwise fine. Im knowlegable with the autobody part of cars but not so much with the mechanical side of them. Any help yall could give would be greatly appreciated.

The most recent things Ive done mechanically have been:

New modulator
New plugs (ac delco)
New fuel pump
New fuel filter
New fuel lines
Oil and filter change
New transmission filter and gasket (new fluid obviously)
New struts and mounts


I understand these are all minor fixes I have done, but they are all things that have needed to be done since before the accident. I want to get this car runnin just about perfect before I start usin it as my daily car. Alot of people have said Im completely retarded for fixin my beloved 92 bonneville with 153K miles on it. But I dont care. I LOVE this car!

Sorry bout the long post and all the extra stuff yall dont need to know, but Im tryin to make sure I get everythin fixed before I take my baby out and run her everyday. If there is anythin else yall can suggest I do, please tell me as Im not really that smart when it comes to cars.
Paco.McGraw is offline   Reply With Quote
Old 02-14-2006, 01:22 AM   #2
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

oil pressure sender...

$30-40 part... worth a shot

usually when they go bad, the peg at 120 ALL THE TIME... thats why when you say it goes down when you get to temp that it confuses me...

if it stayed at 120 all the time, 100% its the sender unit
harofreak00 is offline   Reply With Quote
Old 02-14-2006, 01:43 AM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jun 2005
Location: Mcallen TX
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Paco.McGraw is on a distinguished road
Default

Thanks man. Ill check it out tomorrow when I get out of class or on friday cause Ill have most of the day off I think. Ill let you know how it works out. Thanks again!
Paco.McGraw is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
oil pan oil level sensor mdrose64 1992-1999 2 04-08-2007 11:37 PM
replaced water pump found some oil in the water pump cavity cjpenny89 1992-1999 3 09-13-2006 12:15 PM
Low oil pressure sensor in oil pan... Bob Dillon 1992-1999 9 05-11-2006 09:23 AM
Changed the oil Pump Pickup and still Bad Oil Pressre?? WickedJstr 1992-1999 4 10-31-2005 12:06 AM
93 SSEi Oil Pump Problem JimmyFloyd 1992-1999 9 08-25-2004 10:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.