Changed the oil Pump Pickup and still Bad Oil Pressre?? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-30-2005, 11:34 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2005
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
WickedJstr is on a distinguished road
Default Changed the oil Pump Pickup and still Bad Oil Pressre??

I just replaced the oil pump pickup in the bonne and it seemed to be a little clogged and the problem still persists. Only now its a little different now it might go up to 50 lbs at start up cold vs staying at 40. Now the gauge will sweep all over the place from low (red mark) to back at 50 untill the car gets to 210degrees. Then it stays low around the red mark it only went off once the buzzer after i put it in. Well i'm at the point now where i dont even care i'm going to wait till next week or so i have yet to replace the sending unit i guess thats my next bet i dont knoww here else to go with this if anyone has some ideas.
WickedJstr is offline   Reply With Quote
Old 10-30-2005, 11:44 AM   #2
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,857
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

OMG, please use some periods.

have you replaced the oil pressure sending unit? and you said the car still runs @ 210? did i understand correctly, but your oil pressure drops to red?
rjolly87 is offline   Reply With Quote
Old 10-30-2005, 12:25 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2005
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
WickedJstr is on a distinguished road
Default

lol yeah that was a little rambiling it'* early for me still lol, Yeah it still runs at 210 and goes in the red. Only when it'* up to temp.
WickedJstr is offline   Reply With Quote
Old 10-30-2005, 10:46 PM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2005
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
WickedJstr is on a distinguished road
Default

anyone have any ideas where to go from here?
WickedJstr is offline   Reply With Quote
Old 10-31-2005, 12:06 AM   #5
Senior Member
Posts like a Supercharger
 
Join Date: Apr 2004
Location: Endwell, NY
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
sellncars is on a distinguished road
Default

I would try a real guage first. This will tell you exactly what kind of pressure that you have. If you have a friend that has an Autometer mechanical oil pressure guage or equivelant, give it a shot.



Good luck,
Sellncars
sellncars is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Changed my fuel level sensor and gas gauge still not working! Overdrive 2000-2005 6 07-21-2014 12:46 PM
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Changed MAF and Bonnie still runs like crap? trixster68 1992-1999 0 07-31-2009 07:40 PM
Where can i get an Oil Pump Pickup?? WickedJstr 1992-1999 4 10-23-2005 08:11 PM
BAD one liners. Bad, really really bad, but still funny. BonnieBrougham Lounge 3 12-16-2004 06:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.