Just replaced supercharger. Ran then died. Now code 58. - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-23-2002, 12:51 PM   #21
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

The crank sensor can be a PITA to change, but not expensive. You're talking 2-3 hours, working through the RF wheelwell. If you're sure VATS isn't the problem, it might be worth shotgunning that sucker. It'll cause the ignition problems you think you're seeing, but I've never heard of a 'flaky' one. They either work, or they go kaput. None of this on again off again crap. You may have some crud on it that makes a detectability difference with the discriminator rings, but I'm not the crank sensor expert. If your fuel system looks good, ignore the cam sensor.
willwren is offline   Reply With Quote
Old 11-24-2002, 01:37 AM   #22
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2002
Location: Missouri
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
RyanSSEi is on a distinguished road
Default

Well, I don't know. I am not going to just put some parts on and hope they fix it. I will try to trouble shoot the car. If it ends up being a pain or looking expensive, I will part the car out. Easy as that. I guess it may potentially be a "boneyardville" soon....

Seriously. If anyone needs some parts, I have a brand new supercharger with 2 different diameter pulleys, new GM SRTA transmission, operating trac control and ABS, brand new CD transport in the CD player, good heads up and gauge cluster, white wheels, brand new balancer, and a bunch more. I'll sell the whole car for what I have in it at this point or I'll part. Sheesh, now I know why I like F bodies so much...

Ryan
RyanSSEi is offline   Reply With Quote
Old 11-24-2002, 03:56 PM   #23
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

It sounds like you need to get a good service manual, or take it to the dealer. In the service manual, there are many different types of flow charts that tell you what to do when you get the code 58.

Is your engine cranking every time you turn it? If so, it sounds like it may be a loose ground or power to your Pass Key II system. There is a wire that goes between the Pass Key II and the PCM that tells the PCM to enable the injectors. That signal is what appears to be intermittent.

It is probably caused by the weakest link, in other words, the battery, ignition feed, or ground to the Pass Key II; the Pass Key II itself; the signal to the PCM; or the PCM itself.

It sounds like an intermittent electrical problem, which can be tough.
fuddyduddy121 is offline   Reply With Quote
Old 11-26-2002, 03:25 PM   #24
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2002
Location: Missouri
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
RyanSSEi is on a distinguished road
Default

Iam going to pull the supercharger back off tonight and see if maybe the supercharger to intake gasket was sucked in due to insufficient flow through the supercharger. This would be due to the larger pulley that may have not allowed the air to flow; just a shot in the dark. Like I said, it ran great until I hit the throttle then it just died.

Ryan
RyanSSEi is offline   Reply With Quote
Old 11-26-2002, 07:52 PM   #25
Senior Member
Certified GM nut
 
Join Date: Aug 2002
Location: Kalamazoo, MI
Posts: 1,838
Thanks: 0
Thanked 0 Times in 0 Posts
95BonnevilleSESC is on a distinguished road
Default

Good luck, I've been following this thread and I hope you get it resolved.
95BonnevilleSESC is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
95 started running rough then died thizzelle707 1992-1999 8 07-30-2009 07:07 PM
XBOX 360 - Lasted 30 minutes then died.... Hans Lounge 13 04-15-2008 12:13 AM
Replaced supercharger now hesitation and code 41 gotbeer 1992-1999 11 03-08-2007 11:33 PM
A/C Problems - Cold then HOT then Cold then Hot!!!!! nick s 1992-1999 13 04-22-2006 11:40 AM
Rough acceleration, Died, Started, Blue Smoke, Died again... DannyM 1992-1999 38 09-01-2005 11:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.