Horn doesn't work - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-20-2010, 07:45 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2009
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
schnutzy is on a distinguished road
Default Horn doesn't work

My horn no longer works, for a while it only worked sometimes. What are some things that could cause the horn to not work? I am hoping to fix it this weekend, just do not know what to look at.

It is a 93 bonneville. The airbag light is not on, so I don't thikn its the clockspring(note sure if it has one, i know its an issue on jeeps, and one way to tell there is if the airbag light is on, and the horn doesnt work).
schnutzy is offline   Reply With Quote
Old 10-20-2010, 07:47 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Start by checking the plug at the horn. Might be corroded. Have someone press the horn and see if you have voltage at the plug.
Danthurs is offline   Reply With Quote
Old 10-21-2010, 10:34 PM   #3
Senior Member
Posts like a Supercharger
 
Join Date: Sep 2005
Posts: 195
Thanks: 0
Thanked 6 Times in 5 Posts
imidazol97 is on a distinguished road
Default

Quote:
Originally Posted by schnutzy View Post
My horn no longer works, for a while it only worked sometimes. What are some things that could cause the horn to not work? I am hoping to fix it this weekend, just do not know what to look at.

It is a 93 bonneville. The airbag light is not on, so I don't thikn its the clockspring(note sure if it has one, i know its an issue on jeeps, and one way to tell there is if the airbag light is on, and the horn doesnt work).
Check for power at the relay in the relay center.
Attached Thumbnails
Horn doesn't work-95lesabrerelays.jpg  
imidazol97 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Horn doesn't work CrAzyD Everything Electrical & Electronic 7 01-27-2006 02:37 PM
ABS, traction control doesn't work 95 sse jeffreyeffrey 1992-1999 8 04-21-2003 05:14 PM
radio doesn't work help! rwe62382 1992-1999 13 03-12-2003 05:58 PM
Spedometer doesn't work!?!? Buddha Jones 1992-1999 4 09-25-2002 08:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:51 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.