ABS, traction control doesn't work 95 sse - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-18-2003, 03:42 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2003
Location: alden mn
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
jeffreyeffrey is on a distinguished road
Default ABS, traction control doesn't work 95 sse

I'm glad to find a forum on bonnevilles! I've had a 95 SSE for a year and a half now and neither the ABS or the traction control have ever worked on it. I slam on the brakes and they lock right up. especially the Front Left one. The traction control has never worked either. doesn't even light up when you touch the button. I've just driven it this way because I'm afraid of what a mechanic will ask for $$ to fix it. Are these problems related? is there a modulator out? Computer problem? Let me know if anyone has ever had probs like this.
jeffreyeffrey is offline   Reply With Quote
Old 04-18-2003, 03:46 PM   #2
Senior Member
Posts like a Northstar
 
Join Date: Feb 2003
Location: Mount Vernon, Ohio
Posts: 530
Thanks: 0
Thanked 0 Times in 0 Posts
con10der is on a distinguished road
Default Re: ABS, traction control doesn't work 95 sse

Quote:
Originally Posted by jeffreyeffrey
I'm glad to find a forum on bonnevilles! I've had a 95 SSE for a year and a half now and neither the ABS or the traction control have ever worked on it. I slam on the brakes and they lock right up. especially the Front Left one. The traction control has never worked either. doesn't even light up when you touch the button. I've just driven it this way because I'm afraid of what a mechanic will ask for $$ to fix it. Are these problems related? is there a modulator out? Computer problem? Let me know if anyone has ever had probs like this.
Well the first place to look is your codes...from there...there are wheel sensors on all four wheels...usually when one goes...total system is shut-down..hence "no light"...

Is there a abs light lit??? If so...it is indicating a problem...this light should only come on at start up...then goes off after "arming" abs/traction control system...

GOOD LUCK.....
con10der is offline   Reply With Quote
Old 04-18-2003, 03:58 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2003
Location: alden mn
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
jeffreyeffrey is on a distinguished road
Default

no ABS light. the light does come on during ignition but goes off just like there is nothing wrong.
jeffreyeffrey is offline   Reply With Quote
Old 04-18-2003, 04:38 PM   #4
Senior Member
Posts like a Northstar
 
Join Date: Feb 2003
Location: Mount Vernon, Ohio
Posts: 530
Thanks: 0
Thanked 0 Times in 0 Posts
con10der is on a distinguished road
Default

Well then it is up to you...May have to have codes read...Not sure how much that cost'*...mine I can do myself (1993)...to a point that is..

Good Luck
con10der is offline   Reply With Quote
Old 04-18-2003, 05:54 PM   #5
Senior Member
Posts like a Turbo
 
Join Date: Apr 2003
Posts: 342
Thanks: 0
Thanked 1 Time in 1 Post
Steve LS is on a distinguished road
Default

Our ABS light and traction light began staying on about a month ago. 97 Olds LSS. Just like you Im putting up with it. We had been turning the traction control off all winter anyhow. Id reather have the wheels spin a little than listen to the noise that thing makes all the time. Dont really need either but we paid for them when we bought the car, so eventually I have them fixed. Tired of looking at the lights.
Steve LS is offline   Reply With Quote
Old 04-18-2003, 06:13 PM   #6
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default Re: ABS, traction control doesn't work 95 sse

Quote:
Originally Posted by jeffreyeffrey
I'm glad to find a forum on bonnevilles! I've had a 95 SSE for a year and a half now and neither the ABS or the traction control have ever worked on it. I slam on the brakes and they lock right up. especially the Front Left one. The traction control has never worked either. doesn't even light up when you touch the button. I've just driven it this way because I'm afraid of what a mechanic will ask for $$ to fix it. Are these problems related? is there a modulator out? Computer problem? Let me know if anyone has ever had probs like this.
Do you feel a pulsation in the pedal when your wheels start to skid?
fuddyduddy121 is offline   Reply With Quote
Old 04-18-2003, 06:25 PM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2003
Location: alden mn
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
jeffreyeffrey is on a distinguished road
Default

no there'* no pulsation. It'* just like the car doesn't even have ABS. I've been looking through the postings here and it sounds like wheel sensors may be the culprit. I replaced the front wheel bearings last fall and saw those sensors, they did look sort of corroded. If I clean them up could that do the trick?
jeffreyeffrey is offline   Reply With Quote
Old 04-18-2003, 07:10 PM   #8
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

I would think that a bad speed sensor would light the antilock light and/or throw a code.

I would check all of your ABS system fuses.

It is possible one of the ABS relays has gone bad or the valves inside the PMV have gone bad. You can test the valves with a scan tool.
fuddyduddy121 is offline   Reply With Quote
Old 04-21-2003, 05:14 PM   #9
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

Also check your brake fluid in the master cylinder reservoir. If it'* not actually at the Full mark, add fresh DOT 3 brake fluid until it is.

The system will shut down ABS and Traction Control, and light both ABS and Traction Off warning lights if it detects that it hasn't got enough fluid to operate with.
acg_ssei is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ABS/Traction light on...but i still have ABS ptrfair 2000-2005 0 12-11-2007 08:33 PM
Stability Control System-ABS-Traction Control compyelc4 2000-2005 16 03-06-2007 11:03 PM
Cruise Control doesn't work Maymybonnieliveforevr 1992-1999 10 11-03-2006 03:18 PM
Traction Control Doesn't Work?! petey1705 1992-1999 1 11-18-2005 05:48 PM
cruise control doesn't work...where should i look? malibuolds 1992-1999 17 05-06-2005 01:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:30 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.