guages quit working - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-30-2008, 06:35 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jun 2007
Location: Mason, Ohio
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Sean123019 is on a distinguished road
Default guages quit working

I tried searching and couldn't find an answer directly related to my problem. Today I had to remove my cd player for repairs. After taking it out and turning my car on i noticed that the gas, boost, temp., and oil pressure guage were pegged a half inch from 0. Both screens on the dash (the compass and car/mileage) went blank, and the ac screen shows 2 dashes. I have had the cd player out several times and don't see how it would affect any of that, but find it odd this happened right after i took it out. What are some possible causes?
Sean123019 is offline   Reply With Quote
Old 04-30-2008, 07:07 PM   #2
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jun 2007
Location: Mason, Ohio
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Sean123019 is on a distinguished road
Default

fixed most of the problem, found 3 blown fuses. The only problem now is the boost guage reads high, seems to follow the throttle right just stays on the positive side the entire time. IMy MAP sensor is barely a year old does it just take time for it to readjust?
Sean123019 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1989 stalling/guages not working fierojamey 1987-1991 3 03-31-2007 02:01 AM
Guages Not working and its Not a corrosion problem...... Dutch2005 Everything Electrical & Electronic 30 08-15-2006 01:24 AM
My trip odometer just quit working. Damemorder 1992-1999 15 02-24-2006 09:17 AM
Power seats quit working, Please help. valerka 1992-1999 9 05-26-2004 01:30 AM
My tripometer and odometer quit working (most of the time) zirconx 1992-1999 6 04-20-2004 06:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:05 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.