Gotta love PO171! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-11-2007, 04:50 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: Omaha NE
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
james5275 is on a distinguished road
Default Gotta love PO171!

Hello everyone,
This is my 1st post here on the Bonnie website. Took me a while to find ya.
I'm a proud owner of a 96 LSS, */C'd 3.8. Bought it as a fixer upper, daily driver with 170,000 miles on the clock.
Welp, here'* the story....
After replacing the seized idler, tensioner, and belt for the SC, it has driven just fine. About 1 month after daily driving, the CEL turned on, but driveability was not effected. After filling up the tank, the light turned off. This continued for about 4 months, light turning on and off. Now the light stays on all the time. I scanned for codes and the lovely PO171 comes up.
Here'* what I have done,
Checked the plugs and they do look like she'* been running a little lean (White with some small blistered spots on the insulator).
-Checked the fuel pressure and it is within specs.
-Checked/ cleaned the grounds.
-Cleaned the throttle body.
-Cleaned the IAC seat and plunger.
-Cleaned the MAF.
-Checked for vaccum leaks with carb cleaner.
-Checked the O2 sensor voltage- it IS out of specs with engine off (zero voltage) but within specs engine on.
-After each of these checks, I cleared the codes, but it would immediately set the CEL and PO171 after starting the engine.
I'm not sure what the idle should be, but seems a little high at 1000 rpm. It idles smooth, runs fine, and still gets about 25 MPG.
Any other ideas here? I'm leaning towards the O2 since it is out of spec, but not sure why the engine off values would affect the system.
Thanks everyone for looking, glad to finally find you!
JJ
james5275 is offline   Reply With Quote
Old 11-11-2007, 11:50 PM   #2
Senior Member
True Car Nut
 
radomirthegreat's Avatar
 
Join Date: Sep 2006
Location: Indianapolis, IN
Posts: 4,606
Thanks: 0
Thanked 0 Times in 0 Posts
radomirthegreat is on a distinguished road
Default

Hey, welcome to the forums! Sorry I can't help you with the PO171 code, but at least I can greet you.
radomirthegreat is offline   Reply With Quote
Old 11-12-2007, 12:21 AM   #3
Senior Member
True Car Nut
 
Join Date: Feb 2006
Location: Melrose
Posts: 4,596
Thanks: 0
Thanked 0 Times in 0 Posts
BLACK94SSEi is on a distinguished road
Default

It could either be an O2 sensor or a MAF (Mass Air Flow) Sensor. What kind of Scan tool are you using?
BLACK94SSEi is offline   Reply With Quote
Old 11-12-2007, 12:38 AM   #4
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

Do a search for that code in this section with BillBoost37 as the author. He chased that code around for sometime. I believe new battery cables solved his problem.
Archon is offline   Reply With Quote
Old 11-12-2007, 01:15 AM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: Omaha NE
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
james5275 is on a distinguished road
Default

Thanks for the replies everyone,
After more forum searching and more tinkering with the car, my light is out. FOR NOW!
I forgot to mention that when the CEL would illuminate, the traction off light would also illuminate. I found a post from another user with the same symptoms (Sorry I didn't get the name), and he determined that the removal of his TB screen was the cause. Which by the way, I had also removed shortly after I bought the car. Don't ask why, dumb idea I guess.
Anyway, earlier today I payed close attention to the IAC valve, and cleaned the plunger and seat. Also cleaned the TB. I dont know if these actions actually turned off the light. After connecting the battery and starting the car, the light immediately came on. I drove it to the gas station just down the street, and on my way back, the light turned off!
5 minuites ago I installed the TB screen, so we will see if the light stays off.

A few more thoughts-
-Has anybody else with the PO171 checked their spark plugs to verify if the system is actually lean?
-My car still idles at about 1050-1100, (Since I bought it). How'* your idle?
-Why the heck couldnt the manufacturers stay with CARBURATION!!!!!
-I have an aftermarket cone filter installed
-Idle vaccum is 18-19 in/hg, Max boost is about 4-5 psi.
All scanning was done at autozone, I believe the make was Actron? Thanks again for the greets and help!
JJ
james5275 is offline   Reply With Quote
Old 11-12-2007, 01:25 AM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: Omaha NE
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
james5275 is on a distinguished road
Default

james5275 is offline   Reply With Quote
Old 11-12-2007, 09:08 AM   #7
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

That code actually means the O2 is doing it'* job. The O2 sees the lean exhaust and the PCM compensates to it'* full potential of adding fuel, therefore it notifies you of the issue.

This is bascially seen when voltage is an issue, evap is connected backwards or ..in your case (most likely) the air being drawn in isn't laminar enough due to the screen removal for the MAF to properly read the amount of air passing it.
BillBoost37 is offline   Reply With Quote
Old 11-13-2007, 12:13 AM   #8
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: Omaha NE
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
james5275 is on a distinguished road
Default

Sensitive little ******, are'nt they.
Thanks for the help everyone, hopefully this holds up. I made it to work and back today with no light. Now, on to the next challenge......
JJ
james5275 is offline   Reply With Quote
Old 11-13-2007, 08:08 AM   #9
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Oh.. The MIL aka light comes on if you have two failed start cycles in a row. And turns itself off after three successful start cycles.

This can make the light your enemy. Say you get one good, bad, good, bad, bad.. arrrggghh.

BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
PO171, "Bank 1 lean?" Bob Dillon 1992-1999 9 01-27-2007 12:20 PM
HELP! had the code PO171 show up (fuel system lean bank 1) marksssei 1992-1999 2 07-19-2004 06:38 PM
code PO171 rrounds 2000-2005 1 06-09-2004 03:22 AM
When ya gotta go...ya gotta go.... TrueWildMan Lounge 4 11-19-2003 09:30 PM
PO171 Code? NVSSEI 1992-1999 6 10-10-2003 02:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:40 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.