External Oil Gauge - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-26-2003, 07:14 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2003
Location: Reno, NV
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
dms3reno is on a distinguished road
Default External Oil Gauge

I'm having trouble with oil pressure readings on my '94 SSE.
The mechanic is pretty sure it is the Oil Gauge.
Has this been a common problem for Bonnevilles?
Also they quoted 4-600 for removing the dash, sending it out to be fixed.
Seems a bit much to me. Has anybody added an external oil gauge to their car?
What does this entail? Cost, effectiveness, compatibility...
dms3reno is offline   Reply With Quote
Old 09-26-2003, 07:17 PM   #2
Junior Member
Thread Starter
 
Join Date: Aug 2003
Location: Reno, NV
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
dms3reno is on a distinguished road
Default

Don't feel like covering old gound, so...
Oil pressure monitored as normal while the gauge was acting up.
New sending unit and pump checks good.
After all tests are done it truly seems to be the Gauge.
dms3reno is offline   Reply With Quote
Old 09-26-2003, 07:40 PM   #3
Senior Member
True Car Nut
 
GAMEOVER's Avatar
 
Join Date: Aug 2003
Location: Racine Wi
Posts: 5,146
Thanks: 0
Thanked 0 Times in 0 Posts
GAMEOVER is on a distinguished road
Default

well i'd disconnect the gauge, Buy a pillar pod, autometer psi gauge and install it what ever you do good electrical not mechanical the factory sending unit might not work?
GAMEOVER is offline   Reply With Quote
Old 09-27-2003, 11:38 AM   #4
Member
Posts like a V-Tak
 
Join Date: Jul 2003
Location: toronto
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
bonneville1992 is on a distinguished road
Default

i have a a piller pod and a oil guage, all i had to do was buy a T so i could hook both back up (electic sender unit) so i wouldn't have the ding check gauges light come on. all you will have to do is buy a good length of tubing for the guage to reach the oil hook up.
bonneville1992 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I might be building an external HD... is it worth it? 97NAbonneville1 Lounge 3 08-12-2004 01:30 PM
Adding an external Display to a HUD. Damemorder 1992-1999 2 05-16-2004 12:36 PM
External amp? Dashboard? Chinski Audio (and aftermarket electronics) 4 04-07-2004 09:31 PM
external temp blinking Wolfedog50 1992-1999 12 09-18-2003 01:57 AM
External Transmission filter? Kuhl General GM Chat 5 05-16-2003 05:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:35 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.