EVAP code P1655 - GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

EVAP code P1655

Closed Thread

 
 
 
Old 08-10-2004, 03:22 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2004
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
keystone is on a distinguished road
Default EVAP code P1655

Newbe
I have recently received a check engine light for code 1665. I have checked all connections and lines and replaced the purge valve but keeps setting codes.
I am planning to replace the purge solonoid also? Amyone have eny experience with this code that can help?
Thanks
Keystone
keystone is offline  
Old 08-10-2004, 08:31 AM
  #2  
Senior Member
Posts like a Northstar
 
Join Date: Mar 2003
Location: Brewerton NY
Posts: 551
Thanks: 0
Thanked 0 Times in 0 Posts
karfreek is on a distinguished road
Default

I had an EVAP code a few weeks ago. It turned out the gas cap was loose. Give it a try, you might need a new one.

jay
karfreek is offline  
Old 08-10-2004, 11:46 AM
  #3  
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
willwren is on a distinguished road
Default

Please post your year and model (and any mods) in your sig as soon as you can. If we have that info, we can provide part numbers and great prices on alot of stuff. Location would help, too. I'm guessing PA?
willwren is offline  
Old 08-10-2004, 01:45 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Aug 2004
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
keystone is on a distinguished road
Default 1655

Thanks for the reply

Will try a new cap

Mine is a 1997 bonneville 3.8 non-turbocharged. Location is Ohio Born in PA

Keystone
keystone is offline  
Old 08-14-2004, 02:22 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Aug 2004
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
keystone is on a distinguished road
Default Problem solved P1655 code

Finally solved problem. Turned out to be a broken wire to purge valve down inside the wiring harness. Took time and a lot of searching but the MIL light is off.
Keystone
keystone is offline  
Old 03-30-2018, 02:34 PM
  #6  
Junior Member
 
Join Date: May 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
elcue is on a distinguished road
Default

I have a 1996 Olds LSS. This P1655 keeps coming back.I had a P0300 multiple eng. misfire code. I also had a no.4 cyl. misfire code so I replaced that coil also.Runs good now.
Anyway for the P1655 in 2017 I replaced the purge solenoid but also had to repair a vac leak in the rear of the car right at the fuel filter area in the right rear in front of the tire. A plastic purge system line running along side the fuel line and there is a vac. line rubber coupler in that area. It is about two inches long and is larger on end than the other and was rotten.I could not find the replacement rubber connector so I had to heat the hose I had on one end in order for force it on to the larger end.That was OK for about six months but Bingo P1655 is back followed by a Pending code P1441 Evap system flow during non purge. If there was a scanner that could point out the problem that would be wonderful but so far it has been a total guessing game.I do no know how to test the canister but I have removed it cleaned it and checked it for leaks and reinstalled it about six months back also.
elcue is offline  
Old 03-30-2018, 08:09 PM
  #7  
Senior Member


Posts like a Camaro
 
Join Date: Feb 2015
Location: Earth
Posts: 1,119
Thanked 168 Times in 151 Posts
CathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to behold
Default

Hi eclue,

Looks like you resurrected a thread 4,976 days after the last response. I'm betting the OP has fixed their issue, given up, or gotten rid of the vehicle by now.

If you need help with your ongoing issue, you might want to start a new thread in the Oldsmobile forum.

Last edited by CathedralCub; 03-30-2018 at 08:10 PM. Reason: Added a third alternative
CathedralCub is offline  
The Following User Says Thank You to CathedralCub For This Useful Post:
Soft Ride (03-30-2018)
Old 03-30-2018, 10:27 PM
  #8  
Senior Member


True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,938
Thanked 399 Times in 352 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Thanks CathedralCub^

Yes please elcue create a new Thread, instead of bumping a 14 year old one.
Necrobumping is frowned upon in the forums.
See bumping old threads...https://www.gmforum.com/introduction...2015-a-304557/
Thread Closed.
Soft Ride is offline  
The Following User Says Thank You to Soft Ride For This Useful Post:
Mike (03-31-2018)
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jseklund
2000-2005
15
01-10-2013 07:39 AM
alex98392
1992-1999
3
08-07-2007 02:39 PM
int_53185
1992-1999
1
10-17-2005 09:45 PM
chromebonnie_98
1992-1999
0
11-20-2004 06:25 AM


Thread Tools
Search this Thread
Quick Reply: EVAP code P1655


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.