Electronic Climate Control display problem -- No, this one's - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-30-2003, 03:17 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2003
Location: Oregon
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
bigred is on a distinguished road
Default Electronic Climate Control display problem -- No, this one'*

Still using factory radio/CD player. Controls & brightness on radio perfect.

About 6 years ago all illumination on ECC went black. Stayed off for rest of trip. Next time turned key on worked perfectly. Stayed fine for about 6 months.

Happening more & more now. Sometimes the control will work from 5 to 20 minutes before going black. Sometimes stays black for 10 to 20 minutes, sometimes whole trip. Some days, especially if warmer than 80 degrees, control won't illuminate from start. When controls are black cannot change air functions, blower speed, temperature; cannot enter diagnostic mode.

Has anyone experienced these symptoms before?

My assumption is electronics in control head failing but was hoping someone may have a simple solution (bad wiring connection or similar).

No 92 or 93 Bonnrvilles with Electronic Climate Control head at any wrecker near here.

If I need a new one, can someone give part no. & cost? None of the GM parts websites I've been to lists 92 Electronic with Rear defrost part no.

Thanks for any help & advice.

BigRed
bigred is offline   Reply With Quote
Old 09-30-2003, 06:10 PM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Could be corrosion on the terminals at the back of the control head. Try disconnecting it and reconnecting it several times (like 10 times) and then put the dash back together again. Sounds like the same type of problems plaguing the gauges cluster.

Part numbers in this thread.

http://www.bonnevilleclub.com/forum/...pic.php?t=2418
fuddyduddy121 is offline   Reply With Quote
Old 09-30-2003, 06:27 PM   #3
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

Quote:
Originally Posted by fuddyduddy121
Could be corrosion on the terminals at the back of the control head. Try disconnecting it and reconnecting it several times (like 10 times) and then put the dash back together again. Sounds like the same type of problems plaguing the gauges cluster.
Ayup. The radio drives the display power, but from your description it sounds like you're losing all connections, not just the display driver, so the problem may just be oxidized pins in the connectors rather than anything more serious.
acg_ssei is offline   Reply With Quote
Old 09-30-2003, 07:52 PM   #4
Senior Member
True Car Nut
 
GAMEOVER's Avatar
 
Join Date: Aug 2003
Location: Racine Wi
Posts: 5,146
Thanks: 0
Thanked 0 Times in 0 Posts
GAMEOVER is on a distinguished road
Default

FUDDLY? I CANT ENTER THE DIAGANTIC MODE ON MY CAR 1994SSE MAYBE IM DOING SOMETHING WRONG?
GAMEOVER is offline   Reply With Quote
Old 09-30-2003, 08:24 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2003
Location: Oregon
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
bigred is on a distinguished road
Default

The part no. for the 92 in the above referred thread states "w/o Electric Temp w/ Rear Defroster".

Is 16160288 the part you ordered Fuddy? Does it have both the Electronic Temperature control with exterior temp readings as well as the rear defroster?

Where did you get it new for $125?
bigred is offline   Reply With Quote
Old 09-30-2003, 09:23 PM   #6
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Quote:
Originally Posted by bigred
The part no. for the 92 in the above referred thread states "w/o Electric Temp w/ Rear Defroster".

Is 16160288 the part you ordered Fuddy? Does it have both the Electronic Temperature control with exterior temp readings as well as the rear defroster?

Where did you get it new for $125?
Where does it say that? I just pulled my old 93 control head off the shelf and the number matches: 16160288. That'* what you need. It has electronic temperature control, exterior temp, rear defrost, etc.

You can order at www.gmpartsdirect.com for $104.

That'* not the one I ordered - I needed a 1994 control head because of my electrical problems with the radio.

By the way - do you have any climate control trouble codes stored?
fuddyduddy121 is offline   Reply With Quote
Old 09-30-2003, 09:25 PM   #7
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Quote:
Originally Posted by joe
FUDDLY? I CANT ENTER THE DIAGANTIC MODE ON MY CAR 1994SSE MAYBE IM DOING SOMETHING WRONG?
You know, we still have not had confirmation that the 1994 model will allow diagnostic mode. Press OFF and TEMP UP simultaneously for five seconds or so, and then everything on the display should light up for a few seconds and then it will display trouble codes.
fuddyduddy121 is offline   Reply With Quote
Old 09-30-2003, 11:14 PM   #8
Senior Member
True Car Nut
 
GAMEOVER's Avatar
 
Join Date: Aug 2003
Location: Racine Wi
Posts: 5,146
Thanks: 0
Thanked 0 Times in 0 Posts
GAMEOVER is on a distinguished road
Default

nope no good
GAMEOVER is offline   Reply With Quote
Old 10-01-2003, 01:03 PM   #9
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Must only work for 92 and 93
fuddyduddy121 is offline   Reply With Quote
Old 10-01-2003, 02:58 PM   #10
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2003
Location: Oregon
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
bigred is on a distinguished road
Default

Quote:
Originally Posted by fuddyduddy121
[

Where does it say that? I just pulled my old 93 control head off the shelf and the number matches: 16160288. That'* what you need. It has electronic temperature control, exterior temp, rear defrost, etc.


It says that on the other gmparts sites I went to when I entered the part number.




By the way - do you have any climate control trouble codes stored?
Nope, no climate control trouble codes.

Thank you very much for all your help fuddyduddy.
bigred is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1993 Cutlass Supreme Electronic Climate Control problem WilliamK1974 Oldsmobile 5 01-16-2012 11:21 PM
strange electronic climate control problem googlesomething Everything Electrical & Electronic 7 03-19-2008 05:37 PM
98 electronic climate control problem 98SSE 1992-1999 2 08-02-2004 10:12 PM
Can I put an electronic climate control in a car with manual parallelcircuits 1992-1999 4 05-02-2003 06:24 PM
electronic climate control trouble codes Fordolet General GM Chat 8 11-21-2002 01:19 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:43 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.