Clicking, grinding, or something.... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-21-2004, 09:34 PM   #1
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jul 2003
Location: Ardmore, Oklahoma
Posts: 1,590
Thanks: 0
Thanked 0 Times in 0 Posts
big_boss2010 is on a distinguished road
Default Clicking, grinding, or something....

I start my car and from under the hood in the vacinity of the alternator comes a clicking or some similar noise. When I run my lights or anything else electric the noise gets louder. All the gages are fine. Have any of you had this problem or know what it is?
big_boss2010 is offline   Reply With Quote
Old 04-21-2004, 10:10 PM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Probably an impending rear alternator bearing failure. Get a stethescope on it.
willwren is offline   Reply With Quote
Old 04-21-2004, 10:16 PM   #3
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jul 2003
Location: Ardmore, Oklahoma
Posts: 1,590
Thanks: 0
Thanked 0 Times in 0 Posts
big_boss2010 is on a distinguished road
Default

Thank you for the info. That is what i was told but I wanted a second opinion.
big_boss2010 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Something new, something missing ohenry5 Your Ride: GM Pictures & Videos 7 02-03-2008 09:57 AM
something new (the OTHER "something new") SOCLEANONE Your Ride: GM Pictures & Videos 22 01-23-2005 10:21 PM
Grinding Sound when cold PLEASE HELP JLAudioEclipse 1992-1999 15 03-09-2004 11:18 PM
Low, loud grinding noise when starting pixelmation 1992-1999 10 01-07-2004 11:18 AM
Front end howling/grinding vital49 1992-1999 14 10-14-2003 02:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.