Broke a\c plug - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-13-2010, 04:48 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Mar 2010
Location: Maineville, OH
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
kmalinich is on a distinguished road
Default Broke a\c plug

I reached down the front of the engine bay and I just barely bumped the plug going into the compressor and it broke off. So the male plug was still plugged into the female from the compressor, but the female end had broken away.

I'll try to get a pic up later today...

Am I going to need a new compressor? or is there a way to fix it?
kmalinich is offline   Reply With Quote
Old 06-13-2010, 05:04 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

If it broke off the compressor you will more then likely need a new compressor. I may have one here tomorrow.
Danthurs is offline   Reply With Quote
Old 06-14-2010, 03:24 AM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Mar 2010
Location: Maineville, OH
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
kmalinich is on a distinguished road
Default

Damn. Okay.

You have a PM, then.
kmalinich is offline   Reply With Quote
Old 06-26-2010, 07:32 PM   #4
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Mar 2010
Location: Maineville, OH
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
kmalinich is on a distinguished road
Default

It wasn't the clutch plug. it was the pressure sensor. now i need one of those + the system recharged.
kmalinich is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Serptentine Belt Broke Today throb 1992-1999 28 10-18-2009 02:22 AM
plug wire broke atauri_92 1992-1999 4 05-22-2006 06:41 PM
What's this plug in my trunk? CD changer plug I hope?!?!?!? 02-SLE 2000-2005 3 09-07-2005 10:16 AM
Need Plug Wire Part Number and NGK Plug Part Number!! josho66 2000-2005 11 05-29-2005 01:06 PM
Broke Motor Mount!! READ vols1992 1992-1999 2 12-19-2002 01:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.