Brake light! Please help! - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-14-2010, 02:27 AM   #11
Senior Member
Posts like a Turbo
Thread Starter
 
theedgeofsanity's Avatar
 
Join Date: Aug 2008
Location: michigan
Posts: 359
Thanks: 0
Thanked 0 Times in 0 Posts
theedgeofsanity is on a distinguished road
Default

just to follow up, the master cylinder was bad and after a replacement and good brake bleeding, the chime and light never returned
theedgeofsanity is offline   Reply With Quote
Old 04-14-2010, 02:40 AM   #12
-- SITE DONATOR --
True Car Nut
 
ymmot04's Avatar
 
Join Date: May 2009
Posts: 4,638
Thanked 5 Times in 4 Posts
ymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of light
Default

Thanks for the follow up. Glad to see you got it going.
ymmot04 is offline   Reply With Quote
Old 04-15-2010, 09:19 PM   #13
Junior Member
 
Join Date: Jan 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
satern13 is on a distinguished road
Default

I just had this fixed. It was the harness going to whichever sensor that the ABS computer scan says has something wrong with it. I believe the part was $80 or so... Had the shop fix it, so I wouldn't know how difficult. And this was replaced after a different shop replaced the hub, cuz they said the plug was busted in the hub. And the second shop I took it to said my old hub was probably fine and they replaced it for nothing. So have somebody check out the harnesses and the wiring. Cuz I had EXACTLY the same problem and this was the solution. On a 2002
satern13 is offline   Reply With Quote
Old 05-05-2010, 01:35 AM   #14
Junior Member
 
Join Date: May 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
ratedK is on a distinguished road
Default Always try the simple fix

My 97 was giving me the brake ( ! ) light with the chime every time I would turn. The brake fluid was not low by any means, in fact it was barely below the full line - but it was *just* low enough to slosh away from the sensor. I just topped it off & the problem was resolved.
ratedK is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Check Gages-BRAKE light, trac off light, and Antilock light all on MissRockstar04 2000-2005 9 07-07-2009 05:12 PM
tail light/brake light bulbs... bigj6360 2000-2005 3 02-16-2009 07:53 PM
BRAKE! Dash Light On. Car does not turn over. Please assist. Mischievious_D 1992-1999 5 06-19-2007 02:39 PM
Brake Lines brake lines oh god brake lines disco_dotty 1987-1991 14 01-19-2005 08:38 PM
Will someone please help me with my brake light? sachin528 1992-1999 3 08-23-2002 08:03 PM


Tags
abs, brake light, brakes, chime, master cylinder, tcc, traction control

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:31 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.