DIC & Compass Question (w/pics) - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-20-2005, 07:21 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2005
Location: Winnipeg, Manitoba. Canada
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Dr_Bones is on a distinguished road
Default DIC & Compass Question (w/pics)

Ok, went through the 50 million messages on both these issues (well not 50 million but close) lol and I can't find anything except to clean the contacts and it should help. Well my problem is not that they don't work at all, but that they work (light-up) and are broken. Here is a pic for you to see what I mean.



This is what the panel looks like after starting it up. Here is it closer..



The Compass will turn/circle a bit after starting up the car and then stop at this spot everytime. I've tried everything from cleaning the back of it to setting the differen't modes/areas.



Here the DIC changes everytime I use the car. Sometimes it shows all the stuff and other times just a lamp out or a few doors open. Most of the time though it has about this much on it to all of the stuff lite up. Now the question is, what could be wrong? Computer? Wiring? Just shot parts? Any help or thoughts would be cool.

Thanks in advance guys.
Dr_Bones is offline   Reply With Quote
Old 05-20-2005, 07:38 PM   #2
Senior Member
Posts like a Corvette
 
Join Date: Jul 2004
Location: Winnipeg, Manitoba, Canada
Posts: 1,445
Thanks: 0
Thanked 0 Times in 0 Posts
captainmiller is on a distinguished road
Default

OMG! Another 87-91 SSE from Winnipeg! Finally, after all this waiting...lol. Where abouts in the city are you located?

I take it the compass doesn't move around when you are driving? If not, maybe try calibrating it and see what happens.

Calibration Procedure

In my FSM it says if compass shows right direction after start-up, but does not move while driving the "speed signals are not reaching the display" and you should "check speedometer operation and repair" otherwise replace the instrument cluster. Someone else may have a better suggestion. I am not too sure about the DIC, I have a similar problem. The windshield on the car diagram sometimes takes a couple seconds to appear and it goes out sometimes...not sure why.
captainmiller is offline   Reply With Quote
Old 05-20-2005, 10:20 PM   #3
Senior Member
True Car Nut
 
Join Date: Dec 2002
Location: Halifax, Canada 91SSE / 97SSEi
Posts: 5,857
Thanks: 0
Thanked 0 Times in 0 Posts
Merlin 91/97 is on a distinguished road
Default

Put the year and trim level in your sig......

I've got a spare SSE cluster here..... as far as I know it works.
Not sure of the year of it though..... the only thing wrong with it, is the plastic cover is broken. I was keeping it for spare parts.
Merlin 91/97 is offline   Reply With Quote
Old 05-20-2005, 10:28 PM   #4
Senior Member
True Car Nut
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

Sounds like your DIC Module has taken a crap. This is the module that gives the DIC display, the info it displays. It is located just in front of the ECU [not sure if you can get to it from behind the glove box.. but I think it is possible.

The only thing I can think of, is to get a friend'* module and try it out. It is very possible that the display is at fault, but I could be wrong. Also if your friend is a good one, try borrowing his cluster too.. just in case that is the problem. If neither fix you up, it would be a wiring issue [I am 99.9% sure that is not the issue].

Just in case you were not aware, the DIC is dependent upon the Compass. There are a few parts on the Compass that are required to be operational for the DIC to work [trust me, I have confirmed this]. It may be that your Compass problem is related to your DIC problem.. but I don't think it causes weird occurances [like your situation], just more of, either it works, or doesn't.


-justin
opensourceguy is offline   Reply With Quote
Old 05-21-2005, 01:29 AM   #5
Senior Member
True Car Nut
 
Join Date: Feb 2004
Location: Western MA
Posts: 2,708
Thanks: 0
Thanked 1 Time in 1 Post
randman1 is on a distinguished road
Default

Uuuuuggg. This subject hasn't come up in a while cause I think the rest of us that have wonky displays have just setteled for what we have, or don't have. Consider yourself lucky that you actually have something displaying.

I've seen my displays only when they want to make their show-biz appearances every so often so I can't tell you anything more than what has already been said but I am determined to find out what the problem is. There are two 91s in two different junkyards local to me and I intend on getting the clusters out of both of them. These added to the one I already have and the one in the car I'm picking up tomorrow, I should be able to get a better idea of what makes these things fail. That is unless all of the clusters are crap which wouldn't surprise me. Until then, try to recalibrate the compass and see if that solves at least the one problem.
randman1 is offline   Reply With Quote
Old 05-21-2005, 01:38 AM   #6
Senior Member
Posts like a Corvette
 
Join Date: Jul 2004
Location: Winnipeg, Manitoba, Canada
Posts: 1,445
Thanks: 0
Thanked 0 Times in 0 Posts
captainmiller is on a distinguished road
Default

Wow, I must be lucky then. Both my DIC and compass work pretty much flawlessly. They are both accurate as well.
captainmiller is offline   Reply With Quote
Old 05-21-2005, 08:18 AM   #7
Senior Member
True Car Nut
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

The display part of my Compass display is shot [soon to be fixed], but my DIC works flawlessly as well . I'll soon figure out the problem associated with our clusters, so we can all fix them without buying expensive clusters and whatnot.


-justin
opensourceguy is offline   Reply With Quote
Old 05-22-2005, 12:18 PM   #8
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default DIC

Check the fine wiring in the green harness behind the display. They tend to crack
and loose connection. You may have to take a small wire and jump it if you find a break. Just solder it from location to location.
SSEBONNE4EVA is offline   Reply With Quote
Old 10-24-2005, 02:38 PM   #9
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2005
Location: Winnipeg, Manitoba. Canada
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Dr_Bones is on a distinguished road
Default

Man, forgot all about this post. lol Well time to take the dash apart again and find this DIC module. Guess I should take lots of pics for those who might find the info useful.
Dr_Bones is offline   Reply With Quote
Old 10-24-2005, 03:36 PM   #10
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default dic

My experince with electronics in my opinion is like TV sets. If you can't find anything visibly wrong in the wiring or solder connections you just remove and replace the whole unit.
If the replacing the module doesn't work I think GM has an exchange program for the cluster at one of their vendors.
SSEBONNE4EVA is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
$&)$&*)#&+()#%& )#@(%&#)%*(&+_ Maymybonnieliveforevr Lounge 6 05-02-2007 07:07 PM
Compass Spot Ideas...... (getting rid of the compass) Merlin 91/97 Everything Electrical & Electronic 10 11-15-2004 12:35 AM
SSE Compass and DIC Failure!!!!!!!! SSE001 1987-1991 3 04-08-2003 03:07 PM
compass and dic not working? stormin76 1987-1991 3 04-03-2003 04:40 AM
DIC AND COMPASS PROBLEMS shortstuf212559 1992-1999 7 02-11-2003 02:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:45 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.