Cruise control not operating well. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-28-2005, 09:39 AM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: May 2005
Location: Fredericton, New Brunswick.
Posts: 380
Thanks: 0
Thanked 1 Time in 1 Post
Timothy's Buick is on a distinguished road
Default Cruise control not operating well.

Ok, I know cruise control is for lazy people, I never use it, unless I am on the highway, the cruise actually gets worse mileage than using the foot. (some hills i am able to climb, TCC engaged, but speed is reduced slightly, with cruise, it just wants to get up to the same speed, and wastes gas)
I just wanna say the cruise works!!

I know there was a TSB, and its a common problem. Everyone should have had the problem, opne time or another (if not, lucky you). What was the problem? Or is it not always the same problem?

Thanks!
Timothy's Buick is offline   Reply With Quote
Old 09-28-2005, 09:51 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

I'm unaware of a TSB on it. At this point, you might have vacuum leaks. Check the vacuum and ensure you don't have leaks to the cruise module. (assuming it operates off vac like the 92-99 bonnies)
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Cooling fans not operating Help! Bonneville94_03 Everything Electrical & Electronic 2 01-30-2009 07:51 AM
cruise control not working - 93 lumina 3.4 harofreak00 Lounge 19 03-16-2007 01:26 PM
Cruise control does not work at all (1994) PPrash 1992-1999 3 09-10-2005 05:51 PM
Cruise Control Problem- NOT Vacuum or Switch Related....? Hans 1992-1999 3 12-14-2004 02:21 AM
Well Well Well ratmfan2118 Lounge 30 05-23-2004 01:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.