89 won't start - two questions - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-05-2007, 09:07 PM   #1
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default 89 won't start - two questions

#1 - I'm trying to fix a car that is going to the junkyard next week. Am I crazy?

#2 - The car was running fine but has been sitting for the last 2 or 3 weeks.
Has fuel pressure while cranking.
Has spark.
Doesn't have fuel injector pulse, SES light suddenly isn't coming on & fuel pump isn't getting the 2 second prime. I thought the ECM crapped out but decided to check for power. It'* getting 12 volts to the ECM but I don't think any of the grounds are working. Does anyone know where the ECM grounds terninate?
Technical Ted is offline   Reply With Quote
Old 10-06-2007, 12:13 PM   #2
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default pulse

My first thought if you have no injector pulse is to check the ICM or connector. The fact that it has spark tells you the crank sensor is working.
SSEBONNE4EVA is offline   Reply With Quote
Old 10-06-2007, 12:24 PM   #3
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

My answers -
#1 - yeah, maybe I'm crazy but I prefer to think of it as curiosity with a major dose of stubbornness.

#2 - I'm afraid I left out the most important part of the story. I decided to switch back to the Magnavox ignition incase anyone here needs a Delco unit. Make sure you reconnect all three grounds when making the swap. The ECM grounds there!
Technical Ted is offline   Reply With Quote
Old 10-06-2007, 03:29 PM   #4
Member
Posts like a V-Tak
 
Join Date: May 2007
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
hibrad2005 is on a distinguished road
Default Coils

How much better are the Delco coils versus the "stock" and how hard are they to change... if better and not too hard are the answers, how much are you looking for, for them?
hibrad2005 is offline   Reply With Quote
Old 10-08-2007, 04:56 PM   #5
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default ground

Ted, are you saying you left out the grounds and found the problem?
SSEBONNE4EVA is offline   Reply With Quote
Old 10-08-2007, 09:47 PM   #6
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default Re: Coils

Quote:
Originally Posted by hibrad2005
How much better are the Delco coils versus the "stock" and how hard are they to change... if better and not too hard are the answers, how much are you looking for, for them?
Some members have reported a big improvement with the Delco system. I suspect that they may have had a weak coil in their Magnavox system. When my son & I made the swap we didn't think it made much if any difference. It was my son'* car at the time & I really didn't drive it much after the swap, maybe some others will chime in.

The swap itself is easy to do. Here'* a link to the Techinfo article.
http://www.bonnevilleclub.com/forum/...e=article&k=99


Quote:
Originally Posted by SSEBONNE4EVA
Ted, are you saying you left out the grounds and found the problem?
Yep, problem solved. When I pulled the negative battery cable from under the coil mounting bracket the other 2 grounds moved up out of sight. When the car wouldn't start I swiapped back to the Delco system & it still wouldn't fire up. The next morning I traced the ECM grounds back to the engine compartment & put 2 & 2 together.
Technical Ted is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Car just won't start-and windows won't roll down??? Jeff Jacobs 1992-1999 4 10-10-2017 06:42 AM
1994 Silhouette wipers won't start, or start and stop part way dancinmikeb Oldsmobile 1 11-04-2013 01:40 PM
Questions,Questions,Questions.......... dbeast420 Lounge 2 05-06-2006 03:49 AM
Questions questions questions big_boss2010 1992-1999 2 09-06-2003 01:41 PM
two quick questions 2000 Silver SSEI 1992-1999 13 03-08-2003 02:03 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:18 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.