89 lesabre still with engine problems...help - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-10-2007, 04:44 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
fierojamey is on a distinguished road
Default 89 lesabre still with engine problems...help

Hi. My 89 lesabre is still having engine troubles. Ive changed the air intake sensor, the MAF sensor, the throttle position sensor, checked vacuum lines, checked for intake leaks. there are no intake or vacuum leaks. Now this is what the car does still....first..when i turn the ket to the 'on' position the check engine light and overheat light(red exclamation mark) will randomly flash for no reason. I cannot check the codes due to this. When i go to start the car sometimes it will start up fine(however the engine light is ALWAYS on no matter what, or at least flashing constantly), sometimes it wont start at all, or if it starts i cant take my foot off the gas or it will stall. Now when i actually get it running it will usually run for a few minutes then the overheat light will flash and when it does that the car bucks and sputters as if its not getting any gas, and will usually stall. If it does stall it WILL NOT start for at least ten minutes. The car is not overheated, but the computer may think it is maybe? This problem first started out of the blue while driving through saskatchewan, the car ran fine when i bought if, and for 2 days after, then all of a sudden on the highway these problems started for no apparent reason. the car got worse every time i drove it now it will not run for more than a couple seconds if at all. So...
AIT sensor---new
MAF sensor---new
TPS sensor--new
no vacuum leaks
no intake leaks
car white smoke out of exhaust sometimes
car feels like it running lean but burnt 20 bucks in gas in about 60 km'*
car will backfire when trying to start
???!! SPEEDO will work sporadically, show random speed(eg. 150kph for going 40) however all other guages work fine
exhaust smell is VERY strong--new exhaust--lost of water out of tailpipe
mechanically the engine if good, runs very strong when running right-200,000hwy KM
Not possible to check codes due to randomly flashing check engine light
Possible problems..?? Maybe a new computer is needed, maybe there is a short somewhere(although this problem happened all of a sudden out of the blue and gets worse and i smell or see NO burnt or even dirty wires). Im about to give up on this car and junk it. Any help one last time would be appreciated, ANY ideas or possible causes let me know, ill check all of them. Thank
1989 Buick Lesabre Limited
3800 ln3 w 200,000 km'*
fierojamey is offline   Reply With Quote
Old 05-10-2007, 04:57 PM   #2
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

I think you are describing the classic ECM failure for the 88-91 3800'*.... the SES flashing is a dead giveaway for an unhappy ECM..

The Temp light is should be switched and may have to do with a temp sensor separate of the ECM feed..

at this point I'd be willing to try an ECM... any ECM from an 88-90 H or C body will work for you... For 91 an ECM from a Lesabre, Bonneville or Olds 88 should work... Make sure the 8th didget is a C ...

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 05-10-2007, 08:41 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
fierojamey is on a distinguished road
Default reply

thanx for the info. im gonna go get an ecu tommorow from the scrap yard. how much should it cost? less than 100? thanx
fierojamey is offline   Reply With Quote
Old 05-11-2007, 12:41 PM   #4
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default yard

Prices vary from yard to yard. Ours charges $25 for ECU'*. Call around or PM Boosty, he might have one.
SSEBONNE4EVA is offline   Reply With Quote
Old 05-11-2007, 02:29 PM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
fierojamey is on a distinguished road
Default

thanx, im going to get an ecu and ill install it and see if it works. junkyard wanted 50 for it.
fierojamey is offline   Reply With Quote
Old 05-11-2007, 04:53 PM   #6
Senior Member
Posts like a Northstar
 
bastard's Avatar
 
Join Date: Nov 2005
Location: Arkansas
Posts: 694
Thanks: 0
Thanked 0 Times in 0 Posts
bastard is on a distinguished road
Default ECU price

I sold the one off my Volvo 240 for $75. It was only used for two model years and was a little harder to find than these VIN C units. I could have easily gotten twice that much, but I didn't want to gouge anybody.
bastard is offline   Reply With Quote
Old 05-11-2007, 05:47 PM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
fierojamey is on a distinguished road
Default

Went and bought the computer, 57 bucks, installed and the car is running fine now. thanx for the help. also got a new front driver caliper, old one was sticky, suprisingly new caliper was only 19 bucks from carquest.....
fierojamey is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Still fighting idle problems. bonnieman92 1992-1999 10 02-08-2006 06:26 PM
Still having problems with my SES light...HELP PLEASE. suctoes 1992-1999 4 12-15-2005 10:47 PM
Problems, Problems, Problems... swartlkk 2000-2005 2 11-04-2005 08:57 PM
Heater Problems... STILL!!!! Harly_ Qun 1992-1999 2 04-29-2004 10:15 PM
problems, problems, problems big_boss2010 1992-1999 15 04-25-2004 09:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:20 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.