Still having problems with my SES light...HELP PLEASE. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-15-2005, 03:53 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2005
Location: Northwest Ohio
Posts: 95
Thanks: 0
Thanked 0 Times in 0 Posts
suctoes is on a distinguished road
Default Still having problems with my SES light...HELP PLEASE.

I have had this problem with my bonneville since I purchased it in early october. The
SES Light was on but not very bright. When I would try to pull codes It would never go out complety just get a little brighter to display my codes. I was getting a code for the ICM so I changed that. The SES light never went out. So the next time, days later
When I checked for codes There were none. So I cleaned the battery termanals and now the SES light is on so bright I can't even check for codes I won't even blink!HELP!!!!!!!!! What should I do next?
suctoes is offline   Reply With Quote
Old 12-15-2005, 04:01 PM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Are you SURE you're jumping the correct terminals on the ALDL connector?

Have you tried a genuine scantool?

If the answer is yes to both of these, and you still can't communicate with the PCM, try a PCM from a wrecker.
willwren is offline   Reply With Quote
Old 12-15-2005, 09:38 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2005
Location: Northwest Ohio
Posts: 95
Thanks: 0
Thanked 0 Times in 0 Posts
suctoes is on a distinguished road
Default

Yes, I'm sure I'm jumping the correct wires Yes, it would before I cleaned the battery conections, but I have not had it scaned since. :( How much should I expect to pay for a pcm? How hard is it to change the prom chip? :(

Thanks again for all your help!
suctoes is offline   Reply With Quote
Old 12-15-2005, 10:42 PM   #4
Senior Member
Posts like a Camaro
 
Join Date: Dec 2002
Location: Northeast MS
Posts: 1,079
Thanks: 0
Thanked 1 Time in 1 Post
94SSEgold is on a distinguished road
Default

the prom chip is super easy, there are two screws holding a metal cover on the pcm, make sure u wear gloves though cause the static from your hands can be harmful to the prom and the computer, once the cover is removed, the prom should be a blue chip that can be removed by pulling the tabs on each end and pulling up, then put it in the new pcm and reinstall, making sure to wear the gloves at all times

Our 94 has gone through 4 since i have owned it, a mechanic screwed up some wiring in the car, since then it has kinda been a electrical gremlin, but it has been pretty good lately, except the fact that it is in the shop right now:(
94SSEgold is offline   Reply With Quote
Old 12-15-2005, 10:47 PM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

It'* harder to change the PCM than the PROM. Can be kinda a PITA to get it out of there. The prom is under a coverplate with only 2 screws. Get a PCM from the wrecker from any of the following:

[quote]
91-93 Buick LeSabre
91-93 Buick Park Avenue
91 Buick Reatta
91-93 Buick Riviera
91-93 Chevy APV
92-93 Olds 88 or LSS
91-93 Olds 98
92-93 Olds Regency
90-93 Olds Silhouette
90-92 Olds Toronado
90-93 Pontiac Transport


Quote:

And put your prom in it.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
STILL having oddball electrical problem -- help? gssteve Buick 1 02-26-2011 08:30 PM
still having lean bank 1 problems tan96ssei 1992-1999 6 02-24-2008 07:46 AM
WOT problem @NEBF (04,22,06 still having the same problem) Peterg22000 1992-1999 23 04-22-2006 08:50 PM
i am still having some issues with my tempeture. ssesc93 1992-1999 16 06-06-2005 08:35 PM
Coils replaced and O2 too, but still having probs birchymm 1992-1999 24 11-19-2004 12:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:53 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.