87 Bonneville wont start - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-04-2009, 12:52 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Xeviathan is on a distinguished road
Exclamation 87 Bonneville wont start

My 87 Bonneville just stopped running on me while I was driving on level ground. The engine cranks but wont start.
So far here is what i'v checked:

- Im getting a spark in the plugs
- there is fuel pressure in the fuel rail and I changed the fuel filter.
- there are no diagnostic codes reading other than code 12 (normal).
- all fuses are good
- can feel air coming out of the tail pipe while cranking

I can smell fuel after I crank the motor, but I know I didn't flood it.The air filter box got blown off while I was trying to start it due to air/fuel. What else could be stopping the car from starting? Cam sensor possibly?

Anykind of help would be great !

Last edited by Xeviathan; 08-04-2009 at 12:59 PM.
Xeviathan is offline   Reply With Quote
Old 08-04-2009, 01:17 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Does your car have a VATs? They generally don't shut down when driving. Do you have a security light, is it flashing or on steady? A crank sensor could cause it to shut down it it suddenly failed.
Danthurs is offline   Reply With Quote
Old 08-19-2009, 08:56 PM   #3
Member
Posts like a V-Tak
 
Join Date: Jul 2004
Location: Houston
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
87BonnevilleTX is on a distinguished road
Default

I had a similar problem a few years ago. In my case, it turned out that the timing gear broke (I think that'* what it was anyways). After I got it repaired, the mechanic showed me the old one, and the gear was missing several teeth.

Before I got it fixed, the starter worked just fine, and it sounded like it was just about to turn over, but it never did. Hope this helps.
87BonnevilleTX is offline   Reply With Quote
Old 08-19-2009, 09:26 PM   #4
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Xeviathan is on a distinguished road
Default

Trying to determin if its a timing problem or the fuel pump. When I turn the key to "accessory mode" I can hear the fuel pump buzz for three seconds or so. If it was shot would it still do that?
Is there a way to verify the timing gear is broke.. maybe open the oil cap and look to see if the lifters are moving?

Thank you for your help !
Xeviathan is offline   Reply With Quote
Old 08-19-2009, 09:33 PM   #5
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

If your having a VATs problem, the fuel pump will prime, then shut off. As I asked before, do you have a VATs on the car? Is there a chip on your key?
Danthurs is offline   Reply With Quote
Old 08-19-2009, 09:40 PM   #6
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Xeviathan is on a distinguished road
Default

Vehicle Anti-Theft System? Negative. And there is no chip on the key.
Xeviathan is offline   Reply With Quote
Old 08-19-2009, 09:43 PM   #7
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

OK, first thing is to check for spark, pull a plug and lay it on a ground with the plug wire on and crank. Is there a spark? If yes, then test your fuel pressure. If no then check over the coils.
Danthurs is offline   Reply With Quote
Old 08-19-2009, 09:46 PM   #8
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Xeviathan is on a distinguished road
Default

I have a spark, so I'll have to get the pressure of the fuel tested. Thanks for the replies.
Xeviathan is offline   Reply With Quote
Old 08-19-2009, 09:54 PM   #9
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

After you get it tested you will need to check the filter, pump, or relay depending on what you find out.
Danthurs is offline   Reply With Quote
Old 08-19-2009, 10:01 PM   #10
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Xeviathan is on a distinguished road
Default

I recently changed the fuel filter right after it quit running, so its good to go. So its either timing, a relay or the fuel sending unit.
Xeviathan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 bonneville-wont start, wont run backwoodsfab 1992-1999 0 10-09-2008 07:27 PM
1992 bonneville ssei starts, stalls then wont start gilligans_off 1992-1999 65 06-10-2007 07:02 PM
94 Bonneville SSE Cranks but wont start... need advice! henryjacobsen 1992-1999 23 12-30-2006 01:23 PM
1993 bonneville wont start mwaldo27 1992-1999 3 08-17-2006 05:13 PM
Me Wont ooo ooo Me Wont!!! bandit Your Other Rides: Pics & Videos 4 06-18-2006 02:09 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.