Blazer wont start - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Your Other Rides: Pics & Videos Post your pictures of your non-GM vehicles. Also discuss mechanical problems regarding your non-GM (Car vids not yours should be in the lounge)

Closed Thread
 
 
 
Thread Tools Search this Thread
Old 02-27-2008, 04:39 PM   #1
Senior Member
Certified GM nut
Thread Starter
 
redwingsfan34's Avatar
 
Join Date: Jan 2006
Posts: 2,028
Thanks: 0
Thanked 0 Times in 0 Posts
redwingsfan34 is on a distinguished road
Default Blazer wont start

My blazer wont start when its cold out. I can sit there and crank the engine over all i want until the battery dies, but it wont start, it seems like its not getting spark. So i talked to a friend of mines dad (mechanic for the local pontiac dealership) and he said it sounded like the Ignition Coil. So i replaced the coil, and the blazer ran fine for a few days, but today it wont start again.
I was told it had a tune up by the person i bought it from, but i'm not sure what all he did in the tune up.

Anyone have any ideas?
redwingsfan34 is offline  
Old 04-22-2008, 06:47 AM   #2
Senior Member
Posts like a Supercharger
 
Join Date: Sep 2007
Location: Kansas City Mo
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
dscott2000 is on a distinguished road
Default

Ok, to save some money in the long run. I would have an automotive electrician look at it. Just to be safe.. It sounds to me that you have a positive short in the coil wiring. Or, it could be the computer going bad. I really couldnt tell ya what it is. Good Luck!
dscott2000 is offline  
Old 04-22-2008, 07:43 AM   #3
Senior Member
Certified GM nut
 
Join Date: Oct 2006
Location: burb of detroit. 2 miles north of 8 mile Rd.
Posts: 2,028
Thanks: 0
Thanked 0 Times in 0 Posts
samueljackson is on a distinguished road
Default

there ICMs are common to fail on those things.

other than that, id startby checking the battery connections, and clean all corrosion.
samueljackson is offline  
Old 04-22-2008, 09:57 AM   #4
Senior Member
Posts like a Turbo
 
LeSabreUltra's Avatar
 
Join Date: Feb 2007
Location: Alabama
Posts: 494
Thanks: 0
Thanked 0 Times in 0 Posts
LeSabreUltra is on a distinguished road
Default

Quote:
Originally Posted by samueljackson
there ICMs are common to fail on those things.
Quoted for truth. My 4.3 powered S10 just had one go out.
.
.
.
LeSabreUltra is offline  
Old 04-22-2008, 01:07 PM   #5
Senior Member
Certified GM nut
Thread Starter
 
redwingsfan34's Avatar
 
Join Date: Jan 2006
Posts: 2,028
Thanks: 0
Thanked 0 Times in 0 Posts
redwingsfan34 is on a distinguished road
Default

this problem was fixed a long time ago...
this is an old thread
redwingsfan34 is offline  
 
 
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 bonneville-wont start, wont run backwoodsfab 1992-1999 0 10-09-2008 07:27 PM
Me Wont ooo ooo Me Wont!!! bandit Your Other Rides: Pics & Videos 4 06-18-2006 02:09 AM
Car wont start Buggie 1992-1999 1 08-18-2003 07:05 PM
87 SE wont start Damemorder 1987-1991 43 06-29-2003 08:11 PM
Help me out fellas - My Bonny wont start!! CDecker 1992-1999 14 10-24-2002 12:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.