Montana with 3.4 LA1 coolant leaking front cover - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-03-2015, 01:55 AM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
LittleNo is on a distinguished road
Default Montana with 3.4 LA1 coolant leaking front cover

I had to replace my timing chain (which btw was succesful and surprisingly brought many improvements, no more tickering noise on cold starts, smoother engine run), but now I can't get the front cover to stop leaking coolant.

My first guess was a mistake by me when I installed the new gasket (it'* a bit tricky to insert the front cover when you don't have the oil pan removed) so I have done it again with a new gasket (FelPro) without any change on the problem.

The coolant is leaking near the rear banks coolant channel, so I thought it could be a problem with the bold that goes into the coolant channel inside the engine block. So I re-installed this one with silicone on it'* threads. Still leaking.

Any ideas?

The sealing surfaces are clean without any scratches (I did the cleaning and inspection very carefully)
LittleNo is offline   Reply With Quote
Old 08-03-2015, 03:43 AM   #2
Junior Member
Thread Starter
 
Join Date: Aug 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
LittleNo is on a distinguished road
Default

If anybody interests, here'* the condition of the old timing chain:
LittleNo is offline   Reply With Quote
Old 08-03-2015, 01:26 PM   #3
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,146
Thanked 781 Times in 610 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Mileage?

Looked more like a tensioner problem.....

If you can't specifically find the leak, maybe a black light and dye to pinpoint it?
Tech II is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
3400 LA1 throttle body on a 3100 LG8? 2k2cse Buick 2 07-30-2016 04:45 PM
2004 Cavalier: Timing chain cover leaking oil Rhensonsr Chevrolet 2 01-18-2015 12:44 AM
1999 Pontiac Montana Van Front Pass Seat Problem nickb Pontiac 3 05-21-2014 04:24 PM
98 Montana Front Bearing Replacement Maymybonnieliveforevr Lounge 2 11-06-2007 08:54 PM
94 SSE leaking coolant doug 1992-1999 7 01-20-2004 09:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.