car revs like crazy after I removed throttle body - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-27-2011, 09:27 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
splatter85 is on a distinguished road
Default car revs like crazy after I removed throttle body

I just changed out the thermostat in a 03 Grand Prix 3100. When I put it back together it was chugging and dying. I took apart the intake and throttle body and cleaned the crap out of it with intake cleaner. The car no longer dies but it revs randomly and the RPMs will stick at a certain point like 3k or 4k and jump around. The car does this normally and when sensor number 4 from the picture is unplugged (i'm assuming its the throttle position sensor) and also when number 3 is unplugged (i'm assuming its the mass airflow sensor). Anyone know what the problem could be. Also if you could explain the numbered sensors in the picture it would help.
Name:  grandprixthrottlebody.jpg
Views: 183
Size:  89.8 KB
splatter85 is offline   Reply With Quote
Old 02-27-2011, 09:29 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Did you remove the TPS when you cleaned the throttle body?
Danthurs is offline   Reply With Quote
Old 02-27-2011, 11:46 PM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
splatter85 is on a distinguished road
Default

No I didnt remove the tps. Should I remove it and clean it?
splatter85 is offline   Reply With Quote
Old 02-27-2011, 11:54 PM   #4
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

No need to clean it, it'* a potentiometer, so nothing to clean. But you may want to test it. Something tells me it'* not working right. I asked if you had removed it because if it'* put back on wrong it wont give the correct signals. Also check for any vacuum leaks, make sure none of the sensors are disconnected.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
F-150 revs with Defroster 93-SSE Your Other Rides: Pics & Videos 11 02-17-2008 07:00 PM
engine revs as soon as i turn my key - LeSabre ptrfair Buick 1 11-13-2007 08:12 PM
1996 SE starts rough, eventually revs than goes to normal DeeMutz 1992-1999 13 06-09-2007 11:31 PM
89 Lesabre (STARTED) revs high OLBlueEyesBonne 1987-1991 8 03-20-2005 01:28 PM
Throttle Body and Throttle body spacer! DeeGee96SE Performance, Brainstorming & Tuning 5 06-29-2004 01:21 AM


Tags
engine revs, high idle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:00 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.