Coolant Leak... After GT1 cam install - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Performance, Brainstorming & Tuning Talk about modifications, or anything else associated with performance enhancements. Have a new idea for performance/reliability? Post it here. No idea is stupid! (please use Detailing and Appearance for cosmetic ideas)

Reply
 
 
 
Thread Tools Search this Thread
Old 08-17-2006, 07:51 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2006
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Snuggles.bf is on a distinguished road
Default Coolant Leak... After GT1 cam install

After we finnaly finished last night around 2:30 am and 5 days of working on this i have a coolant leak. I think its coming form the LIM gasket that didn't seal properly with the RTV sealant. Is this a correct assumption? Does the gasket just need to seat into the spot or is this a replacement issue?
Snuggles.bf is offline   Reply With Quote
Old 08-17-2006, 08:11 PM   #2
Senior Member
True Car Nut
 
95naSTA's Avatar
 
Join Date: Feb 2003
Location: Philly
Posts: 4,508
Thanks: 0
Thanked 0 Times in 0 Posts
95naSTA is on a distinguished road
Default

Where EXACTLY did you put the RTV?
95naSTA is offline   Reply With Quote
Old 08-17-2006, 08:39 PM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2006
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Snuggles.bf is on a distinguished road
Default

exactly where you showed me on the pictures
Snuggles.bf is offline   Reply With Quote
Old 08-17-2006, 08:41 PM   #4
Senior Member
True Car Nut
 
Join Date: Aug 2004
Location: In your garage, swipin' da lug nutz
Posts: 3,067
Thanks: 0
Thanked 0 Times in 0 Posts
sandrock is on a distinguished road
Default

DId you clean off the intake bolts, clean out the bolt holes, use loctite and torque to spec?
sandrock is offline   Reply With Quote
Old 08-17-2006, 08:48 PM   #5
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2006
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Snuggles.bf is on a distinguished road
Default

yeah we did. i think the RTV just didn't take i was feeling it and it looks like it pushed mostly out and when that coolant was coming threw it just broke threw the RTV.
Snuggles.bf is offline   Reply With Quote
Old 08-18-2006, 01:12 AM   #6
Senior Member
True Car Nut
 
Join Date: Jun 2004
Location: Glendale, AZ
Posts: 3,459
Thanks: 0
Thanked 1 Time in 1 Post
big_news_1 is on a distinguished road
Default

Can you actually see coolant leaking out, or did the level in the overflow bottle just go way down? If the level in the overflow is dropping, it'* because the system is purging out air bubbles in the system. No matter how carefully you fill it, the level in the overflow will drop a whole bunch over the first day or so of driving.

Unless you can actually see it leaking out, just drive it for a couple days and keep topping it off. It should stabilize after a while.
big_news_1 is offline   Reply With Quote
Old 08-18-2006, 01:17 AM   #7
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2006
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Snuggles.bf is on a distinguished road
Default

we figured out what it was it looked like the LIM gasket but in all reality it was the thermistat housing. Well the thermostat O ring.... it was in there all jacked up and had a gash in the side of it. It wasn't blocking the coolant from leeking out. So it was constantly dripping coolant out when i would hit bumps and ****. lol. So im allllllllll GOOD now. Thanks
Snuggles.bf is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
GT1 Cam Break IN procedure Snuggles.bf Performance, Brainstorming & Tuning 4 08-18-2006 01:45 AM
Help....GT1 Cam Shaft Snuggles.bf Performance, Brainstorming & Tuning 13 08-13-2006 04:27 PM
HELP! cam sensor error... and its NOT the cam sensor Sprig Everything Electrical & Electronic 3 06-17-2006 11:13 AM
Car not running right after VS Cam install Habibus 2000-2005 21 07-07-2005 09:36 PM
INTENSE Stage 1x cam install!!!!!!!! part 1 whisky98 2000-2005 6 03-28-2004 11:49 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:38 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.