a/c help - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Oldsmobile When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-05-2006, 07:02 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jan 2006
Location: westchester county ny (cortlandt manor)
Posts: 136
Thanks: 0
Thanked 0 Times in 0 Posts
92olds88royale is on a distinguished road
Default a/c help

i have a good climate control a good compressor and a full charge of freon yet my compressor wont come on and jumping the plug on the metal thing neer the passenger side firewall wont get it to kick on either

also i have a brand new relay on there and all fuses are good


any ideas?

btw the compressor is only 1 year old
92olds88royale is offline   Reply With Quote
Old 05-05-2006, 07:50 PM   #2
Senior Member
Posts like a Supercharger
 
Join Date: Mar 2006
Location: Chicago
Posts: 193
Thanks: 0
Thanked 0 Times in 0 Posts
BlownBuick is on a distinguished road
Default

You might have a bad ground somewhere. I don't know if the clutch uses a wire in the connecter as a ground or the body of the compreser as a ground, but it'* something to think about. Try checking the resistance between the compresser body and the negative terminal of the battery and (if one of the compresser wires is a ground) the resistance between it and the negative on the battery.

With a new compresser and you manually jumping the clutch wires with 12 volts, I would imagine that that could be the only possable cause. (other than a really bad clutch)
BlownBuick is offline   Reply With Quote
Old 05-06-2006, 08:00 PM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jan 2006
Location: westchester county ny (cortlandt manor)
Posts: 136
Thanks: 0
Thanked 0 Times in 0 Posts
92olds88royale is on a distinguished road
Default

i pulled out the relay and jumped terminals 1 and 4 and the compressor kicked right on. so i went out and baught a brand new relay and it worked fine for 2 minutes and then popped the relay again. any ideas?
92olds88royale is offline   Reply With Quote
Old 05-07-2006, 04:44 PM   #4
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jan 2006
Location: westchester county ny (cortlandt manor)
Posts: 136
Thanks: 0
Thanked 0 Times in 0 Posts
92olds88royale is on a distinguished road
Default

fixed it tightened the compressor because it was a little loose and cleaned behind where the compressor mounts so it makes a good contact for a good ground and then put a new relay in and filled it up with some r-12 and now it works great.
92olds88royale is offline   Reply With Quote
Old 05-07-2006, 11:02 PM   #5
Senior Member
Posts like a Supercharger
 
Join Date: Mar 2006
Location: Chicago
Posts: 193
Thanks: 0
Thanked 0 Times in 0 Posts
BlownBuick is on a distinguished road
Default

Glad you got if fixed in time for A/C season.
BlownBuick is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP HELP HELP-Did Pep Boys Damage Bonnie?? mprather 1992-1999 24 02-03-2010 08:21 AM
HELP HELP HELP, EXPERTS PLEASE !! statusplease 1992-1999 8 03-15-2008 06:49 PM
palm help (plz any help is good help) gojo83 Lounge 2 09-24-2007 10:34 PM
Back Three Plug wires NOT Coming off HELP HELP HELP VanFaasenC 2000-2005 1 10-04-2006 02:51 PM
Photoshop help! (FONT help now!) willwren Lounge 13 09-16-2003 03:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.