2002 Olds Alero Hard Brake Pedal - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Oldsmobile When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-10-2014, 10:44 AM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gmfan2014 is on a distinguished road
Default 2002 Olds Alero Hard Brake Pedal

Hello,
I am having issues with 02 Alero. It has a 2.2L eng. The brake pedal is extremely hard to apply. I have replaced the brake booster, master cylinder, abs module. All calipers have been checked and are moving freely. Pads and rotors have been replaced. All brake lines are new from front to back. This has not resolved the hard brake pedal issue.

Any suggestions on possible causes of the brake pedal and what I can do to fix.

Thank you for your time.

Sam
gmfan2014 is offline   Reply With Quote
Old 12-10-2014, 12:23 PM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,146
Thanked 781 Times in 610 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

well, you have obviously opened the system......there is the possibility of air in the system......have you properly bled the system?

before starting the car, pump the the brakes and hold your foot on the brake pedal.....do you have a high hard pedal? Now start the car.....does the pedal drop?

You have a hard pedal, does the vehicle stop ok from a high speed?

Is the red brake light or ABS light on? Have you scanned it for codes?

What was the original symptom, before replacing all these parts?
Tech II is offline   Reply With Quote
Old 12-10-2014, 12:33 PM   #3
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gmfan2014 is on a distinguished road
Default

Hello,

Thanks for your reply! yes the brake have been bled properly. The pedal stays hard after being pumped with the enigne off and then started.

The vehicle stops ok from high speed but you really need to push the pedal. No ABS lights are on and no codes have been stored.

Original symptom happened suddenly. While on highway, the car suddenly slowed down and after pushing on the brake a few times it was ok. It did this a few more times at which point the pedal became hard. Took it to mechanic and the front right caliper was not releasing properly and was extremely hot compared to other wheels - verified with temperature gun. Mechanic replaced Master Cylinder and replace front pads/rotors. Car ran fine expect with hard pedal. Returned to mechanic and ABS module was replaced. Same Hard brake symptom. Then Booster was replaced. Same symptom. Lines were replaced last year and never has an issue.

Thanks
gmfan2014 is offline   Reply With Quote
Old 12-10-2014, 02:37 PM   #4
Senior Member
Posts like a Turbo
 
chevy82's Avatar
 
Join Date: Jan 2014
Location: Missouri
Posts: 396
Thanked 99 Times in 84 Posts
chevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of light
Default

Vacuum source to the booster ok?
chevy82 is offline   Reply With Quote
Old 12-10-2014, 03:44 PM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

what did they do to fix the caliper, the others checked? did they check the check or replace the sliders?
jwfirebird is offline   Reply With Quote
Old 12-10-2014, 03:46 PM   #6
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gmfan2014 is on a distinguished road
Default

Quote:
Originally Posted by chevy82 View Post
Vacuum source to the booster ok?
yes, the booster vacum is ok. This is stumping a lot of people...
gmfan2014 is offline   Reply With Quote
Old 12-10-2014, 04:31 PM   #7
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gmfan2014 is on a distinguished road
Default

Quote:
Originally Posted by jwfirebird View Post
what did they do to fix the caliper, the others checked? did they check the check or replace the sliders?
There was nothing wrong with the calipers. All pins were checked and each caliper was sliding freely. After the Master Cylinder and ABS were replaced, the brakes have been fine except for the stiff pedal.
gmfan2014 is offline   Reply With Quote
Old 12-10-2014, 04:33 PM   #8
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gmfan2014 is on a distinguished road
Default

Quote:
Originally Posted by chevy82 View Post
Vacuum source to the booster ok?
Yes, I performed this test a few minutes ago. While car is off, I pumped the pedal 4 times and on the 5th I held the pedal down. While the pedal was down, I started the car at which point the pedal went down all the way. After pumping the pedal a few more times with the car running, it became hard again like it was before the test.

Hope this helps...

Thanks,
gmfan2014 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 Olds Alero 3.4 Hard Starts -help! JustinRS32 Oldsmobile 3 04-14-2014 10:16 AM
2001 olds alero hard start olds2001 Oldsmobile 6 05-29-2012 09:30 PM
hard brake pedal i-ross1 Buick 2 01-25-2011 09:49 PM
Hard Brake Pedal? The Real Cause and Diagnostics john_doe 1992-1999 2 05-03-2007 03:18 PM
Gas pedal, brake pedal position younghelio 1992-1999 1 03-19-2004 12:10 AM


Tags
brake, brakes, hard brake, pedal

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.