2000 Olds Bravada - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Oldsmobile When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-14-2015, 05:49 PM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2014
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
lst369 is on a distinguished road
Default 2000 Olds Bravada

I have a 2000 Olds Bravada that will not rev over 2000 RPM or drive over 15 MPH. I have changed fuel filter. Fuel pump maintains 60 psi, goes up to 65 when revving. I have gotten an intermittent P0300 code (misc misfire) very occasionally but no other error code. Any ideas?
lst369 is offline   Reply With Quote
Old 04-14-2015, 07:13 PM   #2
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Are you capable of watching live data?
Mike is offline   Reply With Quote
Old 04-14-2015, 11:47 PM   #3
Junior Member
Thread Starter
 
Join Date: Jun 2014
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
lst369 is on a distinguished road
Default

no, i'm not
lst369 is offline   Reply With Quote
Old 04-15-2015, 05:50 AM   #4
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

It'* a long shot, but disconnect the MAF electrical connector start it up and see what happens. It may be a little hard to start, but should stay running.
Mike is offline   Reply With Quote
Old 04-15-2015, 10:18 AM   #5
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,148
Thanked 783 Times in 612 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Exhaust back pressure?

Check for codes?
Tech II is offline   Reply With Quote
Old 04-15-2015, 09:18 PM   #6
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Quote:
Originally Posted by lst369 View Post
I have a 2000 Olds Bravada that will not rev over 2000 RPM or drive over 15 MPH. I have changed fuel filter. Fuel pump maintains 60 psi, goes up to 65 when revving. I have gotten an intermittent P0300 code (misc misfire) very occasionally but no other error code. Any ideas?
Quote:
Originally Posted by Tech II View Post
Exhaust back pressure?

Check for codes?
D
Mike is offline   Reply With Quote
Old 04-19-2015, 12:38 PM   #7
Junior Member
Thread Starter
 
Join Date: Jun 2014
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
lst369 is on a distinguished road
Default

Disconnected the MAF and it made no change.

Sorry it took long to reply but the weather has been miserable here and I don't have a garage right now.
lst369 is offline   Reply With Quote
Old 04-19-2015, 12:43 PM   #8
Junior Member
Thread Starter
 
Join Date: Jun 2014
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
lst369 is on a distinguished road
Default

This condition has come on gradually. First it hitched at 55-60 MPH and you had to take your foot off the accelerator to get some power, then 35 mph became top speed, then 30, then 20. What is perplexing is that other than a P0300 code showning up once, there are no error codes
lst369 is offline   Reply With Quote
Old 04-19-2015, 02:01 PM   #9
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Only other thing I can think of that would cause something like this would be the TPS(throttle position sensor). If they aren't installed correctly, they can cause weird behavior like this. Or if it develops a flat spot, the PCM doesn't know what position the butterfly plate is in. Think of it like the volume control on an old radio. When you turn the volume up and the audio gets scratchy or doesn't do anything, same thing here.
Mike is offline   Reply With Quote
Old 04-20-2015, 08:14 PM   #10
Junior Member
Posts like a Ricer Type-R
 
Join Date: Jul 2012
Location: INDY
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
EZLYCARSICK is on a distinguished road
Default

random mifires can be caused by plugged catalytic converter,If you can unhook converter and see if engine can now rev up or better if you can drive.Have replaced many doing this same thing
EZLYCARSICK is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1997 Olds Bravada Brake Lines jasonl Oldsmobile 8 08-06-2014 06:17 PM
olds bravada Hans Lounge 8 09-19-2007 05:02 PM
Bosch O2 sensor for 2k Olds Bravada 4.3L - Thoughts... swartlkk Lounge 9 08-01-2005 10:14 AM
My 2000 Olds Bravada AWD swartlkk Your Ride: GM Pictures & Videos 25 05-09-2005 09:57 PM
All GM once again!!! Just purchased 2000 Bravada swartlkk Lounge 14 04-24-2005 04:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.