Key in on position only turns on radio & windows - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-11-2012, 11:57 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
tstanek is on a distinguished road
Exclamation Key in on position only turns on radio & windows

RE: 97 GMC Jimmy. Usually when i put the key in the on position, a bunch of dash lights come on, i hear a tone, and the you can hear the fuel injection take place for a second or two. Today, none of that happened. Only the radio turned on, and i could open the windows. My blinkers don't even work with the key in the on position. If i turn the key farther into the starting position, the engine turns over and over and over. Doesn't fire. Is this electrical? Or is my fuel pump causing this? She'* been sensitive when starting lately, sometime requiring me to squirt that starting fluid into the carburetor. ...im ignorant when it comes to cars...if i said something incorrectly i apologize and will explain more in detail if you point out what i may have said incorrectly. Thank you for your help in advance. As a father of 4 your incite is priceless.
tstanek is offline   Reply With Quote
Old 07-12-2012, 07:24 AM   #2
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,641
Thanked 995 Times in 772 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

I'm wondering if your 97 has the same ignition switch issues as the 2000 series blazers?
Mike is offline   Reply With Quote
Old 07-12-2012, 07:51 AM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

that noise you normally hear is the fuel pump priming, sounds like thats not happening now. wether its the ign switch or something in the pump circuitry you are going to have to find out. i would first try swaping the relay if you have one thats the same, and checking to see if any fuses are blown. if the fuse is alot of times the pumps draw more as they go out and pop fuses.
jwfirebird is offline   Reply With Quote
Old 07-12-2012, 08:11 AM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

looked through the diagram check fuse 10 or 15(keyed power) to see if power is getting out through the ign switch. if not your switch is bad.
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
trans slips only on left turns. any ideas? eltatertoto Buick 16 04-22-2014 08:33 PM
'97 Bonneville - Blower motor only turns on when hot SignOfZeta 1992-1999 10 06-06-2011 09:03 AM
Key turns...swishing sound from console Viper 2000-2005 31 02-08-2009 11:29 PM
$&)$&*)#&+()#%& )#@(%&#)%*(&+_ Maymybonnieliveforevr Lounge 6 05-02-2007 07:07 PM
Air only blows out top & bottom ducts only. Not the VENT vols1992 1992-1999 3 11-10-2002 11:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:01 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.