I need a tech who knows lights and fuses - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-30-2012, 05:59 PM   #1
BANNED
Posts like a Supercharger
Thread Starter
 
Join Date: Aug 2009
Location: Wahpeton, North Dakota
Posts: 183
Thanks: 0
Thanked 0 Times in 0 Posts
zigger21 is on a distinguished road
Default I need a tech who knows lights and fuses

I have a 2004 Yukon Denali XL and I just installed LED taillights for it. My rear lights and brake lights will not work but my Turn signal and Back up lights work just fine. I have been all over the fuses in the hood and on the side panel on the driver side. What Fuse am I looking for. They worked great for two weeks and then it just quit working so it has to be a Blown fuse because the Turn lights light up the LEDs and the Back up lights work great its just the regular running lights and brake lights wont work. I had the key in the acc spot and the brake lights worked for a minute and then quit again. Can anyone help. Please
zigger21 is offline   Reply With Quote
Old 06-30-2012, 06:17 PM   #2
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

Have you looked at the wires in the lights themselves? You might have a corroded or bad connection there somewhere. If it was a fuse, you wouldn't have gotten them to work for a second when you turned the key to "ACC"
2k2cse is offline   Reply With Quote
Old 06-30-2012, 06:22 PM   #3
BANNED
Posts like a Supercharger
Thread Starter
 
Join Date: Aug 2009
Location: Wahpeton, North Dakota
Posts: 183
Thanks: 0
Thanked 0 Times in 0 Posts
zigger21 is on a distinguished road
Default

Quote:
Originally Posted by 2k2cse View Post
Have you looked at the wires in the lights themselves? You might have a corroded or bad connection there somewhere. If it was a fuse, you wouldn't have gotten them to work for a second when you turned the key to "ACC"
I just installed them 2 to 3 weeks ago and I havent had it out of the garage except on nice days. Bit Ill check the connections next because I could swore it was a fuse. because its happening on both of the tail lights. Im at my wits end the left and right signals work, reverse light, no running lights or break lights? Im in desperate need of some help. I hope its the connection in the back but why would they work for 2 weeks then quit. I appriciate all of your help/ Ill check the connections now and let you know in a minute. Take Care
zigger21 is offline   Reply With Quote
Old 06-30-2012, 06:29 PM   #4
BANNED
Posts like a Supercharger
Thread Starter
 
Join Date: Aug 2009
Location: Wahpeton, North Dakota
Posts: 183
Thanks: 0
Thanked 0 Times in 0 Posts
zigger21 is on a distinguished road
Default

I checked the connection on the lights and they are installed right. Its where you just plug in the LED connector into the Stock connector and they look good no corrosion or anything.
zigger21 is offline   Reply With Quote
Old 06-30-2012, 06:35 PM   #5
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

Have you tried plugging the stock lights back in to see if they work? Sometimes certain vehicles don't like leds in the tail lights. Also, do you have a 3rd brake light in the back window? I'm not sure if the Yukon has one or not.. if you do, and that don't work either, it could be a fuse..
2k2cse is offline   Reply With Quote
Old 06-30-2012, 06:39 PM   #6
BANNED
Posts like a Supercharger
Thread Starter
 
Join Date: Aug 2009
Location: Wahpeton, North Dakota
Posts: 183
Thanks: 0
Thanked 0 Times in 0 Posts
zigger21 is on a distinguished road
Default

Quote:
Originally Posted by 2k2cse View Post
Have you tried plugging the stock lights back in to see if they work? Sometimes certain vehicles don't like leds in the tail lights. Also, do you have a 3rd brake light in the back window? I'm not sure if the Yukon has one or not.. if you do, and that don't work either, it could be a fuse..
Thank Bud Ill try that, I really appriciate all of your help. Truly it means alot that this site has such nice people. I was on the Tahoe/Yukon forum and they were like 12 year old kids knit picking at everything you said wrong. I snapped like I should not have and fired back and got me kicked off which I regret because that is totally not me but they kept picking and picking. Very unprofessional. Thank for being helpful and most of all courtious.
zigger21 is offline   Reply With Quote
Old 06-30-2012, 06:40 PM   #7
BANNED
Posts like a Supercharger
Thread Starter
 
Join Date: Aug 2009
Location: Wahpeton, North Dakota
Posts: 183
Thanks: 0
Thanked 0 Times in 0 Posts
zigger21 is on a distinguished road
Default

The 3rd stop light over my back hatch is not lighting up either,
zigger21 is offline   Reply With Quote
Old 06-30-2012, 06:43 PM   #8
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

Quote:
Originally Posted by zigger21 View Post
Thank Bud Ill try that, I really appriciate all of your help. Truly it means alot that this site has such nice people. I was on the Tahoe/Yukon forum and they were like 12 year old kids knit picking at everything you said wrong. I snapped like I should not have and fired back and got me kicked off which I regret because that is totally not me but they kept picking and picking. Very unprofessional. Thank for being helpful and most of all courtious.

Always glad to help, or at least try to anyways

A lot of other forums aren't as well taken care of, for the lack of a better word, as this place. That'* one thing I like about the forum, so many great people who are always willing to help

Quote:
Originally Posted by zigger21 View Post
The 3rd stop light over my back hatch is not lighting up either,
Alright, it sounds like it is a fuse now. There should be a fuse called "brk lmps" or similar. I'm not sure if its in you passenger compartment or under hood fuse box though. I'll see if I can dig up something.
2k2cse is offline   Reply With Quote
Old 06-30-2012, 06:58 PM   #9
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

Take a look at the ones I circled in red. This is in your under hood fuse box:

I need a tech who knows lights and fuses-under-hood-fuse-04-denali.jpg

and this is on your drivers' side dash

I need a tech who knows lights and fuses-ip-block-04-denali.jpg
2k2cse is offline   Reply With Quote
Old 06-30-2012, 07:16 PM   #10
BANNED
Posts like a Supercharger
Thread Starter
 
Join Date: Aug 2009
Location: Wahpeton, North Dakota
Posts: 183
Thanks: 0
Thanked 0 Times in 0 Posts
zigger21 is on a distinguished road
Default

Thanks a ton, Ill try it after cool down because Im getting pissed and hot I need a break and go back later when Im not so wound up; Thank you. Take Care
zigger21 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
need a map of the fuses ismkwdfkit Everything Electrical & Electronic 2 04-08-2010 12:47 PM
I need someone who knows bout this stuff ChiTownRiv General GM Chat 11 11-16-2007 08:08 AM
debating... anyone who knows motorcycles check this and help FiReDeViL Lounge 5 05-28-2007 10:10 AM
Lights,lights, and more lights... fdh01bonneville Detailing & Appearance 3 05-13-2007 05:19 AM
So, who knows about websites and updating them? driverjohn2005 Lounge 6 12-11-2006 05:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:36 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.