97 sierra runs rough in rain after tune up - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-22-2013, 12:36 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
big carl 84 is on a distinguished road
Default 97 sierra runs rough in rain after tune up

I have a 97 gmc sierra K-1500 with a 5.7. If there is heavy dew, rain, or any kind of moisture it runs really rough. Changed dist.,rotor, plugs, plug wires, ignition coil, and ignition control module and no help, have any ideas.
big carl 84 is offline   Reply With Quote
Old 07-22-2013, 07:50 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

possibly crank position sensor wires, the wires go on the pass side from by the coil down to by the crank pulley, follow them down make sure they didnt touch the exhaust or chafe anywhere. you can try on a dry day misting water on wires with the engine running and see if it stumbles. slight possibility if you dont find anything that cheap parts may not be liked by this engine, delco or delphi stuff is usually recommended, especially the cap the way it is its easy for the power to arc across on the cheap ones
jwfirebird is offline   Reply With Quote
Old 07-22-2013, 08:52 AM   #3
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Fill a spray bottle with water, and at night when it is dark spray a mist all around the engine compartment (engine running) when it is dark outside. If you see blue sparks anywhere that is the source of your problem.
2kg4u is offline   Reply With Quote
Old 07-22-2013, 10:13 AM   #4
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

First thing that comes to mind is the MAF.
Do you run a K&N air filter by chance?
I have heard of some cases where high humidity, or rainy days, could cause an over oiled K&N air filter to release oil, which too much of it on the MAF'* hot wire can cause the car to run rough.

When it is dry/hot are there any similar problems?
Or do they seem to go away when dry/hot?
WilliamE is offline   Reply With Quote
Old 07-22-2013, 11:17 PM   #5
Junior Member
Thread Starter
 
Join Date: Jul 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
big carl 84 is on a distinguished road
Default

Thank you for the suggestions. I will try them all and see what happens as soon as I get the chance. WilliamE, it seems like it runs fine when dry and hot or at least not as noticeable.
big carl 84 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
97 97 Bonneville rough idle after start then runs fine. Mattus Pontiac 12 11-24-2011 03:19 PM
Runs OK then idles rough after 15 min bobref 1992-1999 4 06-17-2009 10:02 PM
runs rough for few minutes after restarting when hot billha 1992-1999 10 12-21-2007 12:28 PM
Rain Rain Rain & Ummm More Rain!! ( pics & vid clips BLACK94SSEi Lounge 6 05-15-2006 01:49 PM
Rain Rain Go Away... MOS95B Lounge 10 06-20-2005 07:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:35 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.