2007 yukon xl no crank - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-19-2013, 01:35 PM   #1
Junior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
jaire8886 is on a distinguished road
Default 2007 yukon xl no crank

I have a 2007 yukon xl. Came out of store and vehicle would not start. No crank. Dash lights up poeer windows radio work. Power door locks and remotes don't work. Also can shift vehicle into gear without puting foot on brake. And reverse lights stay on with key on. Code p1682. Replaced bcm. No change. Cleaned battery terminals and 175 amp fuse. Tested battery. Monitor range nsensor shows gear position. Tested relays underhood. Jumped starter relay and will crank over. Need advice anyone seen this
jaire8886 is offline   Reply With Quote
Old 09-19-2013, 03:48 PM   #2
Senior Member

Posts like a Camaro
 
Join Date: Aug 2013
Location: Northern California
Posts: 1,014
Thanked 164 Times in 130 Posts
75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold
Default

I would try a ignition switch.
75 racer is offline   Reply With Quote
Old 09-19-2013, 04:27 PM   #3
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

I agree. I would normally say neutral safety switch, but those other symptoms indicate the ignition switch might be a good place to start.
2kg4u is offline   Reply With Quote
Old 09-19-2013, 05:05 PM   #4
Junior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
jaire8886 is on a distinguished road
Default

Ok.I will try that..ill let you know
jaire8886 is offline   Reply With Quote
Old 09-20-2013, 02:13 PM   #5
Junior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
jaire8886 is on a distinguished road
Default

ok.installed ignition switch no change. Monitored neutral switch. Trans range reading properly on scan tool. Need more advice. Any more ideas out there
jaire8886 is offline   Reply With Quote
Old 09-20-2013, 03:26 PM   #6
Senior Member

Posts like a Camaro
 
Join Date: Aug 2013
Location: Northern California
Posts: 1,014
Thanked 164 Times in 130 Posts
75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold
Default

Hmm this is odd because the p1682 indicates a voltage drop past 9 volts. Is the code still active? What kind of scanner do you have? Can you look at PCM data and compare it to other modules data like the abs module? Seems like if the power and grounds are in good shape the PCM might be going Wacco.
75 racer is offline   Reply With Quote
Old 09-20-2013, 03:40 PM   #7
Junior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
jaire8886 is on a distinguished road
Default

I'm using a snap on scanner. I can communicate with all modules.
jaire8886 is offline   Reply With Quote
Old 09-20-2013, 03:47 PM   #8
Junior Member
 
Join Date: Sep 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
lovroyd88ale is on a distinguished road
Default

Check the positive starter cable if its "Loose" or secure enough connection ur starter wont kick over. If not maybe a Relay went bad
lovroyd88ale is offline   Reply With Quote
Old 09-20-2013, 03:54 PM   #9
Junior Member
 
Join Date: Sep 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
lovroyd88ale is on a distinguished road
Default

Excuse me I didnt read clearly. How bout bad crank shaft position sensor .I had a problem in my 93 old 88 royale . I had power ever where else but engine would not turn over only if I put the key in real fast & stared as quick as possible then it would start . I pinched a the for the crank sensor I dont know if this helps but stay stong
lovroyd88ale is offline   Reply With Quote
Old 09-20-2013, 11:13 PM   #10
Senior Member

Posts like a Camaro
 
Join Date: Aug 2013
Location: Northern California
Posts: 1,014
Thanked 164 Times in 130 Posts
75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold
Default

Quote:
Originally Posted by lovroyd88ale View Post
Excuse me I didnt read clearly. How bout bad crank shaft position sensor .I had a problem in my 93 old 88 royale . I had power ever where else but engine would not turn over only if I put the key in real fast & stared as quick as possible then it would start . I pinched a the for the crank sensor I dont know if this helps but stay stong
If it was a crank sensor he would have a crank no start issue. And since you can communicate with other modules including the bcm which you said you replaced the data line isn't compromised. I would say you need to get a diagram of the PCM inputs and check contanuity of the power and grounds and make sure the 5v reference has acceptable voltage and hasn't been ground by a bad sensor or wiring.
75 racer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2007 GMC Yukon bloomco GMC/Chevrolet Truck/SUV 6 12-31-2013 10:27 PM
2007 Yukon low oil pressure RobPegausch GMC/Chevrolet Truck/SUV 2 12-11-2013 11:16 AM
2007 Yukon burning oil acarrera GMC/Chevrolet Truck/SUV 15 05-03-2011 11:43 AM
2007 Yukon XL Burning Oil maineac89 GMC/Chevrolet Truck/SUV 9 01-04-2011 08:37 PM
A tie with a yukon BonneMan95SE General GM Chat 8 12-16-2003 01:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:33 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.