2004 GMC Envoy XUV - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-01-2013, 08:07 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
johnnie is on a distinguished road
Default 2004 GMC Envoy XUV

My battery recently died but before it died I believe it had low voltage and therefore the computer(ecm) received a low voltage signal. The problem is all the gauges except for speed and rpm are not registering. Also the batt indicator , abs, air bag, and brake lights are on. The car is running fine but it'* like the ecm needs to be reset. I took the battery out of the car for at least an hour before replacing it with the new one. I checked fuses also. Any help anyone can provide would be appreciated. Thank you. Once again this is a 2004 Envoy XUV model 4wd 6cyl.
johnnie is offline   Reply With Quote
Old 12-02-2013, 08:20 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

judging by what works must be the class 2 data from pcm that is the problem. so i would reset the battery again leave it off a while, if not make sure that wire is good.
Attached Thumbnails
2004 GMC Envoy XUV-04envoyipc_zpsf7ba404c.png  
jwfirebird is offline   Reply With Quote
Old 12-05-2013, 10:45 PM   #3
Junior Member
Thread Starter
 
Join Date: Dec 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
johnnie is on a distinguished road
Default

Thank you. Everything is working good.
johnnie is offline   Reply With Quote
Old 12-06-2013, 08:32 AM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

what did you do?
jwfirebird is offline   Reply With Quote
Old 12-06-2013, 09:54 PM   #5
Junior Member
Thread Starter
 
Join Date: Dec 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
johnnie is on a distinguished road
Default

I disconnected the battery and reconnected again and this time it worked.
johnnie is offline   Reply With Quote
Old 12-10-2013, 04:18 PM   #6
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

best to keep the posts in the thread so if people have this problem in the future it can be accessed.

"Hello this is Johnnie with the Envoy XUV model that you helped out. Got a question everything seemed fine but after not driving it for a couple of days I started it and all the gauges once again didn't register (exept for RPM and speed). Any thoughts? I disconnected the battery again hoping the ecm would reset but nothing changed. I was thinking maybe the alternator?"


the connection from the ipc to the pcm may be intermittent. i would take the battery cables off, take the cluster loose, inspect the gray wire there for looseness and anything funky in the connector, reseat it. then take the pcm c1 connector off and look at the dk green wire there looks like pin 58 or 59 depending which engine. then put the pcm plugs together and reconnect the battery and see what happens. if nothing i would measure the resistance on that wire from the pcm to the ipc. if thats good must be something in the pcm or ipc
jwfirebird is offline   Reply With Quote
Old 12-10-2013, 07:48 PM   #7
Junior Member
Thread Starter
 
Join Date: Dec 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
johnnie is on a distinguished road
Default

Ok will do thank you sir.
johnnie is offline   Reply With Quote
Old 12-11-2013, 10:24 AM   #8
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

let us know what you find
jwfirebird is offline   Reply With Quote
Old 12-26-2013, 09:01 AM   #9
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

"First of all Happy Holidays. OK this is Johnnie with the Envoy that you were trying to help. I didn't try what you told me too last because I think the solution is something different. So what happen is after not starting the truck for a couple of days the battery died out. I went to auto zone thinking it was the alternator but they said it was fine. I also did the trick where you start the car and disconnect the battery to see if it would stay running and it did. By the way the battery was only 2 weeks old. I then went out of town for 2 days and came back home to a dead battery that was only a week old. Do you have any thoughts? Any help is appreciated. I still have the same symptoms I first told you about."


sounds like you have a drain some where.

https://www.gmforum.com/trouble-shoo...w-test-293647/
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
System too lean gmc envoy 05 Holden GMC/Chevrolet Truck/SUV 3 02-15-2015 10:39 AM
2004 GMC Envoy XUV hotrodlincoln1961 GMC/Chevrolet Truck/SUV 2 01-15-2014 04:45 PM
Turbo GMC Envoy ONE OF A KIND! Turbo_Envoy Your Ride: GM Pictures & Videos 8 06-29-2013 09:44 PM
My brother is very lucky..... 2003 Envoy Accident Merlin 91/97 Lounge 36 08-17-2003 05:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.