1998 c 1500 wt problem with pass lock - GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat

GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

1998 c 1500 wt problem with pass lock

Old 10-28-2018, 07:22 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
mgebo52 is on a distinguished road
Default 1998 c 1500 wt problem with pass lock

I think I have a problem with the pass lock system . When it first became a problem you would go to start it and it would imediatally stall out , no power to the fuel pump. Let it sit for 10 minutes and it would start no problem . It got worse over time . I now have to disconnect the battery ground for 10 minutes then reconnect wait a few more minutes then it would start . the last week I takes three or four tries like I mentioned above before it starts. Once its running it will be fine for 3 -4 days , sometimes 2 weeks. When I take it to the dealer and leave it it never seems to do it , they say they can't find the problem unless it fails to start when the have it . This has been going on for the two years I have owned it . I bought it with 62k on it it now has 92k. I used to think I was resetting the computer each time I disconnected the the ground cable but not sure any more . the key does not have a chip built in it like some. I replaced the cylinder and key and also the cylinder case . I was told the presence of a key sends a code to allow the truck to start . any help would be great.thanks
mgebo52 is offline  
Old 10-28-2018, 09:30 AM
  #2  
Senior Member

True Car Nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,808
Thanked 1,050 Times in 804 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Not sure what you mean by cylinder case....do you mean the PassLock sensor?

When you say dealer, are we talking a GM Dealership? If yes, did they replace the key, lock cylinder, and case?

Yes, the vehicle may have started every time for them, but did they scan for "B" codes as well as "P" codes?

If the key, cylinder and case(Passlock sensor?) were replaced by a GM Dealership, this pisses me off......should be able to fix their own cars....

The connections between the PassLock sensor and the EVO/Passlock module should have been checked first.......the other possibility is the EVO/Passlock module....

When the vehicle doesn't start, if you do not do those procedures you try, will it continue not to start? If yes, then unfortunately, what may need to be done is have the vehicle towed to the GM shop when it won't start, and have them attempt to start the vehicle while having a Tech II connected to see if the Passlock signal is getting to the EVO, and then from there to the VCM....

Basically what happens is, the PassLock sensor sends a signal to the EVO, and it in turn sends a signal to the VCM....without this signal, the VCM will stop firing the injectors......that is why you have an initial start and then it dies....
Tech II is offline  
The Following User Says Thank You to Tech II For This Useful Post:
CathedralCub (10-28-2018)
Old 10-30-2018, 05:16 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Oct 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
mgebo52 is on a distinguished road
Default

Thanks for the help,. I had it towed to the dealer Sunday because it wouldn't start. I went there today and there are too busy to look at it so I went and tried to start the truck and it started first try. Could the ing.module you mentioned work intermittently ?
mgebo52 is offline  
Old 12-26-2018, 03:52 PM
  #4  
Member
Posts like a V-Tak
 
Join Date: Jan 2008
Location: IL
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
fast68 is on a distinguished road
Default

can be anything from a bad body ground cable or wire corroded dirty loose under hood, or connector in circuits of the theft system, or dirty or worn key cylinder sensor or wires broken loose intermittent. and so on. im working on a 99 cavalier with passlock 1 early style with module in back of the IPC and it stalled out while running driving out of the blue and theft light was stuck on solid no blinking(except only right after cranking) and engine will start(rough though) then it would immediately stall out(theft system telling pcm to shut off injectors etc) i found that the neg batt cable for body was realyl rusted corroded junk bad so i replaced end of cable and now the theft system works and car will start run but run horribly and barely and just stalls when you try to do abything witty the accel pedal,, so something else is going on with the injection or ignition system. gonna oull plugs and read them and go from there i tried checking all sensors values voltages etc with the OBD II scan tool and sensors all check out ok like the CTS and TPS and so on.. maybe the ICM is dying or a bad spark plug or a wire or fuel pressure pump weak or FP feed weak power source through the wire or weak ground wire issue etc.


and FYI for anyone everyone PK system is the one with resistor in the key. passlock is the one with resistor value coming from inside the lock cyl sensor and no resistor in key. and there was early version and then the later version, the early version had a small module controller in the back of the IPC and no body control module control. later on in early 2000s and up etc was controlled by PCM and not the IPC anymore and was also using the BCM, unlike in the early version of passlock.,

and then the PASSKEY systems had about three versions, AFAIK, see these in the bonnevilles and monte carlos and such cars mid late 90s etc, the little resistor in the key.,
fast68 is offline  
Old 12-26-2018, 08:18 PM
  #5  
Senior Member


Posts like a Corvette
 
Join Date: Feb 2015
Location: Earth
Posts: 1,475
Thanked 223 Times in 199 Posts
CathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to behold
Default

It'* been almost two months since mgebo52 posted on this,. I'm guessing we'll never know what happened.
CathedralCub is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
19gmc71
GMC/Chevrolet Truck/SUV
7
02-26-2015 06:20 AM
19bonnie95
General GM Chat
3
05-12-2007 10:08 AM
faisalmali
1992-1999
1
10-11-2004 10:43 AM


Thread Tools
Search this Thread
Quick Reply: 1998 c 1500 wt problem with pass lock


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.