Suspension/Steering Issue - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-09-2012, 10:46 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2010
Posts: 77
Thanked 0 Times in 0 Posts
tyrael2304 is on a distinguished road
Default Suspension/Steering Issue

I have a 97 Bonneville SSEi with 174000 miles on her. I've been having some issues with the steering and suspension lately. I'll tell you what I've replaced. Front and rear shocks/struts. Sway bar bushings. Stabilizer links. Sub frame bushings. Ball joints. Outer tie rod ends. Control arm bushings. The C/V joints have been inspected several times and as far as I've been told, the inner tie rod ends are ok. Here'* the issue I've been having. 1) When I initially accelerate and occasionally when I turn, I hear a loud clunking noise. It doesn't make the noise as long as the vehicle is in motion or I'm not turning. 2) When I turn, the car seems to dip quite a bit and feels loose. I've had the vehicle aligned twice over the last 3000 miles and the tires/wheels balanced as well. 3) She doesn't handle as well as she should considering I have KYBs on the rear and Moogs on the front... I'm attempting to figure out what the clunking noise is and why my steering feels loose after two alignments. Along with the "dipping" feeling while cornering. I know it'* difficult to make an assessment based on written words as opposed to driving the vehicle but any suggestions would be greatly appreciated. I'm adept when it comes to my vehicle and any and all maintenance for her. So please, again, any suggestions would be great. Thank You!
tyrael2304 is offline   Reply With Quote
Old 11-10-2012, 12:47 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

what are your front struts i dont think moog makes them? did you replace the strut mounts when installing them? have someone check the engine mount? strut tower stabilizer loose?
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Air suspension issue 00 SSEi DanSSEi00 2000-2005 3 05-03-2009 07:29 PM
MAJOR rear suspension issue RJGill84 2000-2005 25 07-01-2007 01:49 PM
solid suspension or keep air suspension (1968) slow_azz92bonne Classics (Star Chief and 1957 to 1986) 4 08-09-2005 01:12 AM
Steering/Suspension issue. karfreek 1992-1999 9 03-15-2004 08:52 PM
SSEi Rear suspension issue rhamby 1992-1999 7 06-26-2003 11:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.