speedometer? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-15-2006, 01:49 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2006
Location: Near St. Louis MO.
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
dragon62243 is on a distinguished road
Default speedometer?

Had a lot of problems with gauges when i got my 94 ssei only one left is the speedometer. any suggestions? could someone post a pic of the speed sensor and its location? HELP!!!!! lol

Thanx
Scott
dragon62243 is offline   Reply With Quote
Old 11-15-2006, 08:09 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

The sensor (I think it'* called VSS) is located in the transmission. If I recall correctly it is possible to relplace it without having to pull the transmission.

Someone who had done it should be along shortly. If not..I'll pull out a manual tonight when I get home.
BillBoost37 is offline   Reply With Quote
Old 11-15-2006, 09:07 AM   #3
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

VSS or Vehicle Speed Sensor is located at the end of the passenger side drive shaft output. It is on the differential housing. Best way to get to it would be raise the front of the car off the ground, get underneath and look up. It is located directly behind the engine oil pressure sensor.

Disconnect the wire, remove the one bolt holding the sensor in place, and pull out.

Connect a DVM set to continuity(sp) and pass a piece of metal in front of the sensor. It should beep at you everytime you pass the metal in front of it.
Mike is offline   Reply With Quote
Old 11-15-2006, 09:56 AM   #4
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2006
Location: Near St. Louis MO.
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
dragon62243 is on a distinguished road
Default

ok already replaced that with one i know works. already replaced the gauge cluster and still having the same problem. is there a fuse or relay????? HELP!!!!
dragon62243 is offline   Reply With Quote
Old 11-15-2006, 10:09 AM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Unless you had shifting issues also, the VSS couldn't have been the issue. The PCM relies on that input to know when to shift to what gear.

How about you tell us WHAT your problem with the speedo is, and be as specific as possible.
willwren is offline   Reply With Quote
Old 11-15-2006, 10:27 AM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2006
Location: Near St. Louis MO.
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
dragon62243 is on a distinguished road
Default

ok i can do that. When you start the car all the gauges "reset" except the speedo the needle never ever moves at all. no matter what you do. other than that the car shifts and drives normally.

Scott
dragon62243 is offline   Reply With Quote
Old 11-15-2006, 10:30 AM   #7
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Except for the gauge sweep, the speedo does function properly?
BillBoost37 is offline   Reply With Quote
Old 11-15-2006, 10:32 AM   #8
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Also assuming the HUD reads correctly? Details, details. Give them all.
willwren is offline   Reply With Quote
Old 11-15-2006, 10:41 AM   #9
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2006
Location: Near St. Louis MO.
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
dragon62243 is on a distinguished road
Default

no no the gauge never moves EVER no HUD either nothing to tell what speed i'm going. thats the details the gauge never moves for anything under any condition
dragon62243 is offline   Reply With Quote
Old 11-15-2006, 10:45 AM   #10
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Quote:
Originally Posted by dragon62243
no no the gauge never moves EVER no HUD either nothing to tell what speed i'm going. thats the details the gauge never moves for anything under any condition
Ok, does the HUD read zero? Does it display ANYthing? We need to know if that'* related or a seperate issue.

We'll get this narrowed down, then start digging into schematics to further troubleshoot it. We'll get it, it just may take time.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Speedometer Sensor BonneAlien 1992-1999 5 04-13-2004 01:11 AM
Speedometer stoped working! valerka General GM Chat 7 03-12-2004 05:43 PM
HUD and Speedometer problems.. BonneAlien 1992-1999 5 03-05-2004 10:56 PM
Do anyone have directions on how to put speedometer on? ssesc93 General GM Chat 10 02-20-2004 11:21 PM
Help Speedometer problem angel2you Everything Electrical & Electronic 3 02-14-2004 10:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.