Slugish - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-15-2007, 11:48 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Galvez83 is on a distinguished road
Default Slugish

I have a 2000 SLE Bonne and after i went over a puddle under lots of rain it started being slugish and had poor acceleration. The "SERVICE ENGINE SOON" light came on and i went to Autozone to get it read and it came out P0300 which is according to them multiple engine missfires. I tried replacing the spark plugs and wires and no good, what could be the next step or the cause for this problem? The car used to run fine and after the soaking in a puddle it went haywire on me.
Galvez83 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
98 Bonne Slugish after warm up JP007 1992-1999 15 05-16-2010 09:34 AM
Slugish up Hills booc 1992-1999 2 01-10-2008 10:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.