Power Locks only working about 50% of the time. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-14-2005, 11:00 PM   #1
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Mar 2003
Location: Brewerton NY
Posts: 551
Thanks: 0
Thanked 0 Times in 0 Posts
karfreek is on a distinguished road
Default Power Locks only working about 50% of the time.

My power locks are only locking about 50% of the time. This goes for whether it is putting the car in gear, using the remote to lock, or the button. I get a click from under the passengers side of the dash, from a module that is mounted to a plastic plate that is mounted to the fire wall. But the locks will not lock. The 'unlock' function will work 100% of the time.

I have cleaned the ground busses on bot sides of the car, but they are not corroded. So I dont think that is going to help. Any suggestions?

Jay
karfreek is offline   Reply With Quote
Old 12-14-2005, 11:39 PM   #2
Senior Member
True Car Nut
 
Join Date: Feb 2004
Location: Western MA
Posts: 2,708
Thanks: 0
Thanked 1 Time in 1 Post
randman1 is on a distinguished road
Default

Is it just one door that refuses to lock or all of them? A worn bumper is usually to blame for one door but I'd think it would impossible for all 4 to go at the same time. If they are unlocking fine then this means that the wires from the relays are OK because one wire will rest at ground as the other is triggered to +12v. If the "lock" wire was damaged, none of the actuators would unlock as there would be no ground when you press unlock. This leads me to suspect a relay and therefore the RAC module as the lock and unlock relays are built in.

I don't have my manual with me but there could also be one or more inputs to the RAC module that is inhibiting it from locking the doors. This wouldn't explain the click you hear while attempting to lock though.
randman1 is offline   Reply With Quote
Old 12-18-2005, 02:08 PM   #3
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Mar 2003
Location: Brewerton NY
Posts: 551
Thanks: 0
Thanked 0 Times in 0 Posts
karfreek is on a distinguished road
Default

I cleaned the ground busses and they are working 100% for now. The busses did not look dirty or corroded at all, but they are working now, so who knows. I'll keep ya posted.
karfreek is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
power locks only half working christie0278 Everything Electrical & Electronic 4 01-23-2008 09:46 AM
windows,locks,power seats not working TJ'sblackbonne Everything Electrical & Electronic 5 10-08-2005 03:02 PM
Power locks not working correctly alec_b 1987-1991 9 02-05-2005 04:36 PM
Power Locks not working CarSuperfreak 1992-1999 2 06-24-2004 03:28 AM
Power locks not working CarSuperfreak Everything Electrical & Electronic 1 06-23-2004 08:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:33 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.