My hud is not reading the same speed as the speedometer..?? - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-13-2005, 05:45 PM   #11
Senior Member
True Car Nut
 
Join Date: Oct 2002
Location: Groton, CT _NEBF 05, 06, 07_
Posts: 2,703
Thanks: 0
Thanked 0 Times in 0 Posts
markwb is on a distinguished road
Default

Quote:
Originally Posted by BillBoost37
My poor speedo suffers occasional whiplash
My speedo never suffered from whiplash & my HUD reads 0, because I don't have a HUD.
markwb is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Temp gauge and speedometer reading higher than actual values cssorkinman Bonneville GXP/ Northstar Powered Cars 11 02-12-2012 01:04 PM
96 SE - Speedometer Reading Incorrect fanghawk1998 1992-1999 6 07-29-2010 11:18 PM
Speedometer + HUD not working ynos069 Bonneville GXP/ Northstar Powered Cars 26 05-18-2010 06:17 AM
Speedometer and HUD not working ynos069 Bonneville GXP/ Northstar Powered Cars 0 03-26-2010 02:54 PM
Calibrating HUD speed to Speedometer jbtech 1992-1999 2 10-15-2008 03:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.