I thought this was a battery problem but I was wrong. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-01-2006, 06:48 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default I thought this was a battery problem but I was wrong.

A while back when I had my dead battery in the car, the starter would click upon starting. I replaced the battery 2 months ago and that seemed tto solve the problem. Well, I guess not, I just went out to start her to move her, and it wouldn't start. Click. Security light is fine, so I am taking that I have a dirty connection somewhere? Because sometimes the starter will turn, sometimes it won't and sometimes I will crank it and the starter will stop in the middle of cranking like there is a loose or corroded connection. Am I right?
Bonneville92V688 is offline   Reply With Quote
Old 09-01-2006, 07:05 PM   #2
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

i would take off the battery cables and check the connections for corrosion on the Pos and the Neg...we have seen this one before
1993 SLE is offline   Reply With Quote
Old 09-01-2006, 07:18 PM   #3
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

Cleaned the connectors. The positive was wildly corroded. Fires right up now.
Bonneville92V688 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wrong place at the wrong time.. UPDATE bonnie94ssei Forced Induction 19 09-17-2006 06:39 PM
Wrong Just Wrong BLACK94SSEi Lounge 24 03-30-2006 11:44 PM
Not as pretty as I thought, but..... sandrock General GM Chat 3 03-25-2006 08:56 PM
But But But John Deere Boy Lounge 8 07-09-2005 12:05 PM
I thought I've seen everything but....... SSE14U24ME Lounge 3 11-17-2004 03:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:51 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.