high-beam switch *UPDATED* - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-20-2008, 03:23 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jul 2006
Location: Guilford, Maine
Posts: 107
Thanks: 0
Thanked 0 Times in 0 Posts
Prattage723 is on a distinguished road
Default high-beam switch *UPDATED*

my high-beam switch is broken, so i took it apart and i relized that the mechanism that turns the high-beams on is not very good.

so my question is, could i put either a switch like the old cars with them on the floor. Or i noticed the other day wile driving my dads 96 tahoe his high-beam switch has only one click when you pull it and it is really easy to pull, anybody know if i could put a switch in from a gmc 1500 truck?

i will go take pics right now

Name:  04-20-08_1428.jpg
Views: 12
Size:  34.7 KB
i need to know what these three wires are.. the top one is green with a white stripe. If i had to guess, i would think that the middle one is the main power wire. But i dont know with one is low-beam or high-beam
Name:  04-20-08_1429.jpg
Views: 11
Size:  37.3 KB

Name:  04-20-08_1431.jpg
Views: 11
Size:  42.3 KB
this red thing is the reason they dont work, when i try to turn my high-beams off the red piece just slips and doesnt turn the metal piece, witch in turn keeps my highs and lows on at the same time.
Name:  04-20-08_1430.jpg
Views: 11
Size:  48.9 KB
Prattage723 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 SE - Getting high beam switch to work... kparrent 1992-1999 11 08-06-2011 08:13 PM
Two issues: 1. High beam switch and 2. burning smell Skippy1827 1992-1999 2 02-07-2008 01:24 PM
High beam "activator?" not working. Switch and rod maxpower9004 Everything Electrical & Electronic 23 04-05-2006 10:48 PM
UPDATED: Help! Drivers Side High Beam NOT WORKING! SuperchargedFury Everything Electrical & Electronic 8 10-04-2005 06:51 AM
Enabling Low Beam while Hi Beam is on Drifter420 Everything Electrical & Electronic 15 10-22-2003 05:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.