ECM Problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-27-2004, 02:29 AM   #1
Junior Member
Thread Starter
 
Join Date: May 2004
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
59galaxie is on a distinguished road
Default ECM Problem

Is it common for the ecm to make a buzzing noise? It is hardly detectable unless you are right next to it. Has anyone experienced this, thanks for the help.
59galaxie is offline   Reply With Quote
Old 05-27-2004, 02:32 AM   #2
Senior Member
Certified Car Nut
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

I've never noticed mine buzz. It may be a sign of something trying to short. Does everything still work properly? What year (is the ECM in the dash or the engine compartment)?
J Wikoff is offline   Reply With Quote
Old 05-27-2004, 02:45 AM   #3
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

does it have a good ground? i know if mine doesnt have a ground it clicks and makes noise.
harofreak00 is offline   Reply With Quote
Old 05-27-2004, 10:56 AM   #4
Junior Member
Thread Starter
 
Join Date: May 2004
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
59galaxie is on a distinguished road
Default

The year is 1992 and the ECM is under the dash. The old one was acting funny, no start, die going down the road. It would have spark, fuel, and injector pulse, but would not fire. The old ECM made this buzzing noise also but I didn't notice it until i went to change it, who knows how long it had been doing it. With the new used one the car runs fine, but still has the buzzing noise. I have checked several of the grounds are there any a person would recomend. Thank for the help!
59galaxie is offline   Reply With Quote
Old 05-27-2004, 11:03 AM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

I'd bet it'* one of the adjacent relays in the relay center at the base of the A-pillar. They're right next to the PCM. With the ignition on, but car not running, try pulling fuses one at a time until the noise stops. Figure out what circuit it is.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ecm problem guy Buick 8 09-26-2014 07:23 AM
95 Bonneville- ECM problem? RoRomama Pontiac 7 01-20-2013 11:06 AM
ECM code problem/question debbiegary99 1987-1991 8 10-23-2003 10:05 AM
ECM access/removal billha 1992-1999 2 09-02-2002 12:44 PM
ECM access/removal billha 1992-1999 1 12-31-1969 08:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.