97 bonneville electrical issues - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-19-2013, 07:52 PM   #1
Junior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
orazio31892 is on a distinguished road
Default 97 bonneville electrical issues

hey there, just looking for some help !have a 97 bonneville se with 86,000 on it !

recently the car cuts off on me, not all the time, happnd about 5 times ! no warning or anything ! but it always starts right back up ! dont know whats wrong ! no noises or anything, just like cars shuts off ! fuel system is good, no hesitation, no stumbling ! has never not started !! had subwoofers in car, which is why i think my battery gauge was all over the place... checkd the alt and batt and autozone guy said batt is only charged 10 perecent and alt is bad going from 14.2 to 2.0 and just bouncing around ! so i unhooked beats and battery stopped bouncing, seems to still move a little when at stop, or a idle ! check batt and alt again and alt is completley fine, and so is battery, so idk what is wrong! taking outthe beats helped, but car still cuts off !

also when i start car, it starts rough, runs high, engine revs itself up to about 3, scares me...after its done reving battery gauge goes to normal and cars runs smooth and quiet ! maybe it a cold start but idk ! think its the mass air flow sensor or the map sensor!

check engine light on for only
p0104, which is man.absolute pressure or mass air flow sensor
and a evap code, forgt number but it starts with defective gas cap or crack hoses


checked all vacum lines, seem to be fine


question are !

1. is my alt or batt bad? even if the reading are now fine, but still a little movement in batt gauge!

2. anyone have a clue to why it revs itself and calms down after a second or 2? i think it related to the battery prob because like i said while starting and its reving up and i can watch rps go up by theirself, batt gauge is almost in the red, then once kicks down batt gauge goes normal !

3.why is it cutting off? cant be alt or batt! think a sensor maf or map! which 1 should be done first!

other things ive heard !

fuelfilter
throttlebody?plates need to be cleaned


any info would help !

car runs good, just had oil changed, fuel system flush! i think theirs an electrical issue but not sure ! radio turns on and rests by itsself! no dimming lights tho or flickering !
orazio31892 is offline   Reply With Quote
Old 09-20-2013, 08:54 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

you check the boot that comes out of the throttle body toward the front for the evap and fpr? all it has to be is a little cracked looking and it wont hold air. sounds like the alt and or battery is bad because when you put a load on it it cant handle it. and for the quitting i would try disconnecting the maf when its acting up if the car runs there is a problem with the maf
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1991 Bonneville SE Electrical Issues rcwill 1987-1991 2 09-21-2010 03:57 PM
Electrical Issues PLease help. junior5480 1992-1999 1 11-07-2004 10:02 PM
Electrical issues? bonnie90se General GM Chat 7 07-15-2004 11:50 AM
89 SSE electrical issues and more Tonyrodz 1992-1999 15 09-24-2002 12:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.